PureOS byzantium on the phone?

PureOS Byzantium by Purism. Freescale proccesor. Big thanks to all L5 developers.


needs a software patch. Other things are being worked first in Byzantium


Is this a regression? It works in Amber.

I assume so, it worked for me too before upgrading to Byzantium.

The issue is that we have not yet ported to Byzantium the necessary patches for the flashlight to work. We are working on several aspects of byzantium to be able to release it, and simply have not yet got to port that patch.


I guess it should be added in this thread that PureOS byzantium can be flashed onto the Librem 5 – note that this removes anything that was on it before, all data is lost – using the librem5-flash-image script in the librem5-devkit-tools repository (see https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Reflashing_the_Phone.html). To get byzantium, simply use the --dist byzantium option like this:

sudo ./scripts/librem5-flash-image --dist byzantium

Or in my case because I have a Birch device, I use this command where “librem5r2” means Birch or Chestnut:

sudo ./scripts/librem5-flash-image --dist byzantium --board librem5r2

So that’s a convenient way if you want to try out PureOS byzantium, as long as you don’t mind reflashing and thereby losing all your settings and data from your old installation. You can see the different options for the flashing script using this command:

./scripts/librem5-flash-image -h

So other than the flashlight issue, how is it working? There was video about Byzantium on the Librem 5 quite a while back and I was expecting to see it upgrade automatically or instructions for everyone to upgrade to get posted. That hasn’t happened. Did you encounter many other issues?


I admit not using byzantium very much, I mostly tried it to test some specific things now and then, but one other thing that is annoying is that some things do not fit, see:


(the second issue was closed as a duplicate of the first, but it has a few more pictures)

I think this is not a big deal from a developer perspective, they know what it takes to fix it and it will be fixed, but right now it’s an annoyance.

Another thing is that there seems to be a longer delay when opening the Settings app on byzantium compared to amber, I’m guessing it might be simply because more different settings are available so it takes longer to prepare things. Still, it is annoying to have to wait for several seconds when opening Settings. I don’t have an exact measurement but I think it’s about 2 or 3 seconds on amber, and that increased to about 4 or 5 seconds on byzantium.


The only major bug I’ve noticed on Byzantium (except for the flashlight) are some rendering issues in Firefox. Sometimes when scrolling down a page the lower part of the page simply does not render at all until I scroll even further down.

EDIT: Another bug I forgot, my battery indicator often gets stuck showing “charging” even if it’s not.


Is that still happening now? I had hoped it was fixed.

There is this issue about it:

Do you have a way to reliably reproduce it?

A consistent way to reproduce it no, but it’s pretty common.
This is what has been recently been printed in dmesg:

[30175.612038] max17042 3-0036: SOC threshold INTR
[32484.193628] max17042 3-0036: SOC threshold INTR
[32884.775670] edt_ft5x06 2-0038: Unable to fetch data, error: -6
[32934.770914] max17042 3-0036: SOC threshold INTR
[33001.728581] edt_ft5x06 2-0038: Unable to fetch data, error: -6
[33045.781323] edt_ft5x06 2-0038: Unable to fetch data, error: -6

I am using the included charger.


/Post much be at least 10 characters/

1 Like

Now I found a way to reproduce it (the charging symbol shown when cable unplugged):

  • Start with the phone turned on and the cable plugged in
  • Reboot while the cable is plugged in
  • After it rebooted, when the lockscreen is shown, unplug the cable
  • Now it shows the charging symbol in spite of the cable being unplugged

For me it behaves like that every time, but only the first time after reboot (if I plug in the cable again and unplug a second time, then it works).

Can you also reproduce it in this way (on byzantium)?


Good catch, works exactly the same for me! (on Byzantium)


So I flashed Byzantium on my librem 5 Evergreen following skalman’ s instructions from May. Couldn’t do it from my QubesOS (lsusb returns -1) so I tried from my second laptop running MX Linux. Had issues getting uuu installed but I was finally able to get that done (installed the snapd) and I flashed successfully. Yesterday, I made the mistake of hitting the power button when it was attached to the charger. After that the phone wouldn’t start. It would blink green (stay green for a while and then blink quickly). I tried the charging battery recommendations. I even tried another battery (I have two). Although I got it fully charged, it would not start. I ended up having to flash the phone again. Is this a known issue on Byzantium?

You should be able to do it on Qubes OS if you use a disposable sys-usb with all necessary things installed. In such case, you don’t need to connect the USB device to other VMs.

Sorry, I know this might be covered somewhere else, but can’t find it, and this seems a good thread to bring it up:

Is Librem 5 now shipping with Byzantium, and if so, when did that start?


It is, and it started about last month.


That would have been really interesting to have heard about in a blog post. I’ve been waiting for the byzantium upgrade for quite some time. Will my amber version eventually propose an upgrade to byzantium, or do I need to reflash the phone?


I think it will eventually propose that, but first someone would need to provide a means of doing such an upgrade, hence right now you actually do need to reflash if you want to have Byzantium (with the attendant hassle of then re-establishing all your configuration, files, …).