PureOS byzantium on the phone?

A consistent way to reproduce it no, but it’s pretty common.
This is what has been recently been printed in dmesg:

[30175.612038] max17042 3-0036: SOC threshold INTR
[32484.193628] max17042 3-0036: SOC threshold INTR
[32884.775670] edt_ft5x06 2-0038: Unable to fetch data, error: -6
[32934.770914] max17042 3-0036: SOC threshold INTR
[33001.728581] edt_ft5x06 2-0038: Unable to fetch data, error: -6
[33045.781323] edt_ft5x06 2-0038: Unable to fetch data, error: -6

I am using the included charger.


/Post much be at least 10 characters/

1 Like

Now I found a way to reproduce it (the charging symbol shown when cable unplugged):

  • Start with the phone turned on and the cable plugged in
  • Reboot while the cable is plugged in
  • After it rebooted, when the lockscreen is shown, unplug the cable
  • Now it shows the charging symbol in spite of the cable being unplugged

For me it behaves like that every time, but only the first time after reboot (if I plug in the cable again and unplug a second time, then it works).

Can you also reproduce it in this way (on byzantium)?


Good catch, works exactly the same for me! (on Byzantium)


So I flashed Byzantium on my librem 5 Evergreen following skalman’ s instructions from May. Couldn’t do it from my QubesOS (lsusb returns -1) so I tried from my second laptop running MX Linux. Had issues getting uuu installed but I was finally able to get that done (installed the snapd) and I flashed successfully. Yesterday, I made the mistake of hitting the power button when it was attached to the charger. After that the phone wouldn’t start. It would blink green (stay green for a while and then blink quickly). I tried the charging battery recommendations. I even tried another battery (I have two). Although I got it fully charged, it would not start. I ended up having to flash the phone again. Is this a known issue on Byzantium?

You should be able to do it on Qubes OS if you use a disposable sys-usb with all necessary things installed. In such case, you don’t need to connect the USB device to other VMs.

Sorry, I know this might be covered somewhere else, but can’t find it, and this seems a good thread to bring it up:

Is Librem 5 now shipping with Byzantium, and if so, when did that start?


It is, and it started about last month.


That would have been really interesting to have heard about in a blog post. I’ve been waiting for the byzantium upgrade for quite some time. Will my amber version eventually propose an upgrade to byzantium, or do I need to reflash the phone?


I think it will eventually propose that, but first someone would need to provide a means of doing such an upgrade, hence right now you actually do need to reflash if you want to have Byzantium (with the attendant hassle of then re-establishing all your configuration, files, …).

You need to reflash. Byzantium introduces full-disk encryption, and we decided that it’s too delicate to upgrade automatically.

1 Like

Will that include using the smartcard? If so, what state does the card have to be in? e.g. PINs set but no key generated? PINs set and key generated? something else?

I ordered as well the OpenPGP card. Where this must be inserted exactly, instead of the microSD?

Smart card is not used for that yet. But that’s likely achievable by a simple upgrade.


Most definitely not. See: Which official Librem 5 accessories do you recommend?

Under the back of the phone:


“Some” of us are going to need a better tutorial, then. :neutral_face:

1 Like

I’ve already filed relevant issues. https://source.puri.sm/Librem5/developer.puri.sm/-/issues/190


It would be great, if there was an easy, userfriendly way to flash the librem5. I did not find an easy way.

We’re working on it, and that will get announced when it’s done.