PureOS Installer fails when selecting partitions

I’m having trouble on my librem 13 V4.

  • When I got it I installed elementary OS although I and had issues with the machine not entering suspend consistently.
    • From reading I did I believe this is a hardware support issue that exists in debian and it’s don-stream distros with the exception of PureOS obviously.
  • I later switched to KDE Neon and the problem subsided for a while until it didn’t.
  • I decided to fall back to vanilla debian 10.
    • I’m pretty sure debian 10 burnt out my Bluetooth radio but that’s another issue all together.
  • Debian seems to manage suspend better than ubuntu based distros, but not well enough for me to really have confidence in it.
    • Debian 10 also had a number of other problems so I decided to restore PureOS.
  • I successfully re-installed PureOS but when I went to reboot the system for the first time I got an error that I couldn’t recover from during boot and wound up with an unusable system.
  • I was worried that I had destroyed my hardware but I was able to re-install debian 10 again. So I can confirm that I can get an OS running on it. I then went back and tried again to reinstall Pureos but now I’m having the following problem.

I’m trying to reinstall PureOS but the installer crashes on the erase disk option when I put in the matching password. I think my partitions may be a bit out of wack. like I said above I was able to get debian 10 running again as a back up so I could re-partition the disk if need be, but I don’t know exactly what to do. This has been such a headache I just need this computer working again. When I ordered the computer I also ordered an official PureOS install USB key thinking if I had any problems it would be an easy way to reset my computer, that’s the installation media I’ve been using.

Any help would be greatly appreciated.

Best to contact support officially and directly.

If you have a PureOS install USB flash drive, there ought to be 100% reliable instructions that guarantee to give you a vanilla working computer, no matter what you have previously installed - under the assumption that you have no important content on the disk (i.e. you either backed it up for later restoration or you were just trying things out and there is no important content) and hence can blow everything away and start again. Only my opinion of course.

Good call, thanks for the reply. I’ll reach out to support directly, I ended up figuring it out although it’s been an all day process at this point, I had the thought to reinstall debian 10 without llvm Just to straighten out my partitions then try installing PureOS again and that worked. Now I just have to figure out how to fix my bluetooth.

There is discussion in this forum that Bluetooth simply doesn’t work with PureOS because there is no free driver / firmware for the Bluetooth component of the wireless module. You should ask Purism directly to confirm that that is still the current state.

If so, given the history that you document above (you might need a rest), I would hesitate to suggest that you try to work around that by installing non-free software. It depends whether you really need Bluetooth. If you do, there are other topics on doing that. Bluetooth not working out of the box

Yeah thanks for pointing that out. I ended up contacting Purism technical support and that’s what they told me. The person who I interacted with was super helpful and replied very quickly.

1 Like