PureOS Librem15 HD only boots in recovery mode

No luck with the reboot. I think my next step is to try a different USB stick and give PureOS another try. I will keep you posted when I get to that.


I am about at the point I am going to ask you guys for an RMA so I can return the laptop. I am growing more frustrated by the day.

I took the same USB stick I had used with Debian Testing and used the dd command you gave me to burn PureOS 2.1 on it.

Lo and behold, the librem won’t boot it either.

Looking at it, it replaced the bootable partition from Debian Testing (0x00) with a Hidden HPFS/NTFS (Bootable) partition.

That is the same thing I saw on my other USB sticks and I blamed the USB sticks. Now I know it is your iso image that is bad.

So let’s see my travails since August 30th:

  • laptop arrives with a funky disk partitioning and will only boot in recovery mode
  • trackpad gets stuck and the normal commands to undo it won’t undo it until I install Debian
  • you tell me to reinstall
  • I spend days trying to get this open source friendly hardware laptop WIFI to work with Debian with no luck
  • I try to go back to your OS and your ISO installs a funky boot partition the laptop won’t recognize

I work seven days a week. I wanted to buy myself a pre-built laptop to save time. Looks like I could have used as much time buying a much cheaper laptop and installing Debian directly to it. I have never had problems doing that in the past.

Any suggestions?

Dear Richard,

I’m terribly sorry for your troubles. Open source software is not perfect, and it has issues. Unfortunately, we came across one such issue with your laptop. Like I’ve said, as soon as I’ve reported your problems to our devs, they started working on it and eventually fixed it.
As far as USB stick concerns, I must say I cannot reproduce your issue: I used an empty, one partition usb stick, and used commands I posted above, and my computer did boot from it. At this point I can only suggest that you rebuild partition table on your usb stick and try again.

Once again, I’m really sorry for your problems, I would probably feel the same disappointment and resentment as you do now.

Edit: Simple googling your problem lead me to this:

Firstly, do not use more than one method of wireless connection management (wicd, networkmanager) simulatenously. They will fight each other and in the end it will not work. Deauthentication by reason=3 is one possible symptom of this.

If you launch wpa_supplicant manually from command line, it will show you some output of what it is doing:

Hi Richard,

I just tested again PureOS 2.1 (installing it with GNOME disks as described on our download page) and it booted fine into installer. I would like to ask you to download image again (maybe your network got broken at some point and you got corrupted image) and use the same way of installing it on usb as described (be sure you have formated your usb before it).

Once you finish installation and if there is not going to be any network again please provide us output of these commands:

cat /etc/NetworkManager/NetworkManager.conf
cat /etc/network/interfaces

All what I see is that there is no hardware failure and you have enough knowledge to install system on your own which is enough that we fix this. While we can send it back to us for repair (no real hardware repair) you will just loose more days on this. Also if you prefer Debian you’re welcome to use it on your USB installation as well.

Hi Mladen and Zlatan,

Thanks for the encouragement. I formatted my USB stick and started a new download of the iso file. Looks like I won’t get to test until tomorrow as the download is crawling on my network tonight.

Mladen and Zlatan,

Looks like formatting the USB stick did the trick. My Librem recognized it and booted from it. Thank you!

Now I have a new problem. After configuring the partitions, the PureOS installer failed when it tried to create the first partition.

The first time I installed Debian, I remember it asking me if I wanted to enable UEFI because it said the laptop was using old style PCI. I allowed it to do that. Could it be that the PureOS is not UEFI capable?

I poked around the bios reql quick but nothing jumped out as a way to reverse that. Any ideas?


Richard, is the secure boot in BIOS disabled?


Secure Boot: Disabled
Secure Boot Mode: Standard

What should it be?

The error I get is:

The ext4 file system creation in partition #1 of SCSI1 (0,0,0) (sda) failed.

You need to rebuild your partition table. If you can’t do that from within installer, you can use this: http://gparted.org/livecd.php. You need to format the disk and recreate its partition table.

Yes, you can rebuild the partition table from the installer, or so.

You just have to go until the Drive selection step (where the disk partitioning tools have been loaded), then ctrl+alt+F2 to go to the console.
You should then be able to use fdisk to reinitialise the disk, and go on or reboot.

Hi Mladen and Thierry,

fdisk solved the problem!

  • WIFI is working
  • I still have to boot in recovery mode (the fix will be in 2.2?)
  • Gnome Terminal is still broken so I will have to install guake (maybe that will be fixed in 2.2 also?)

All in all, I am back where I was when I first received the laptop. After all of the troubles, I am just going to start using it. Booting in recovery mode seems like a small matter after not having the laptop to use all of these days.

Thanks for all of the help.

This shouldn’t happen, PureOS 2.1 can and should boot in normal mode. Check the logs to see what is happening.

gnome-terminal issue is a known problem, I don’t know if GNOME devs solved it already, but there is a workaround solution: https://puri.sm/forums/topic/pureos-terminal-will-not-work/

Hi Richard,

I too had problem with Gnome Terminal not starting.
I’m not sure of the real cause, but it seems to have been solved by installing “locales-all”.
Maybe it’s overkill, but some locale must be missing when you’re not in the USA, and that you install for fr_BE like I did for my daughter’s Librem13.


Mladen and Thierry,

I looked into the Terminal fix today.

My /etc/locale.conf looks like:

$ cat /etc/locale.conf 

In /etc/locale.gen, I uncommented one line and commented another one:

en_US.UTF-8 UTF-8
# en_US ISO-8859-1

Then I ran locale-gen:

$ sudo locale-gen
Generating locales (this might take a while)...
  en_US.UTF-8... done
Generation complete.

When I tried to start the Terminal. The behavior was the same. Spinning wheel and then nothing. Checking syslog, I found:

org.gnome.Terminal[2569]: Non UTF-8 locale (ISO-8859-1) is not supported!

Makes me wonder if Terminal has a hard coded locale inside of it.

One more thing. I also used apt to install locales-all as suggested. Results were the same.

I tried one more thing.

I put en_US ISO-8859-1 back in play.

Same result.

org.gnome.Terminal[2747]: Non UTF-8 locale (ISO-8859-1) is not supported!
/usr/lib/gdm3/gdm-x-session[2736]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 8

Richard, if that can console you, I hit the same issue myself with the test unit that I received a few days ago… it could happen to anyone, we have to solve the problem fast. Your discoveries here are valuable, and just the fact that you can boot “normally” through recovery mode was very helpful information for me to at least get the machine up and running.

It’s really unfortunate that it happened, to begin with. I have no doubts that the dev team will spend some time investigating and fixing this again, as it seems the previous fix either didn’t do the trick or it did not make its way into the preloaded images… either way, this will be investigated, and I wanted to thank you for your patience and the resourcefulness you’ve shown in helping troubleshoot this! Much appreciated.

Richard, please try this advice:


Seems like this could do the trick, until GNOME developers fix this bug.

I just discovered this thread. I had the same problem about the same time this thread was going on. I’ve just been booting in recovery mode with no issue (after going through some of the same pains). While not ideal, at least it works. Once I get a handle on this operating system, I might download a new version of the OS on a USB stick and re-image the device.


Sorry it has been so long. I have been traveling non-stop so I have not had time to work on my Librem. Now that I am back, I tried the terminal fix and it worked! So now I have both terminal and Guake working. Thanks.


Thanks for the kind words. This is why I like the forums. We can all learn from each other.