Pureos rolling release

But I do (think), as unexpected things might happen:

I don’t understand why you think this: packages versions in Byzantium have definitely diverged way too much from Amber for making it useful to install packages from Amber in a Byzantium system, except maybe some non-essential packages with low-demanding dependencies.

If you are currently in trouble with Byzantium updates, I’d recommend to either not apt-upgrading core packages until conflicts are solved in the repository (if your system works well enough), or selectively upgrading packages including core ones trying to minimize breakage and maximizing updates (which I did with moderate success), or move completely back to Amber. :face_with_raised_eyebrow:

It seems that not all Byzantium users, especially Gnome users, were prepared to bear this testing period of Gnome 3.36 (I wasn’t), but it is understandable for a testing distribution! :sweat_smile:

1 Like

what is not understandable is why in BOTH stable and testing under a GNOME DE you get both the callendar and weather front-ends to be configured to auto default to ON with regards to syncing and location tracking.

if i explicitly thick the Settings > Privacy > Location Tracking to OFF before i even connect to my ISPs gateway to the www then why is it still not in effect when i individually checked the fron-ends of the speciffic apps ?

not to mention the auto-check-with-time-server under Settings > date-and-time … set it to blody MANUAL and OFF by default for Pete’s sake !


As it supports additional useful feature:
~$ sudo aptitude search ~c
~$ sudo aptitude purge ~c

Looks like these packages are uninstallable / unupgradable in byzantium at the moment:
https://software.pureos.net/package/bin/byzantium/fwupd (missing libflashrom1)
https://software.pureos.net/package/bin/byzantium/python3-apt (needs python <3.8 but 3.8.2 is in the repo)


Working on bringing in libflashrom1 into PureOS Byzantium (rolling release) and Amber (stable release) along with a new version of flashrom.


Sorry, I’ve been doing some packaging work and have not been in the forums lately. I’ll try and catch up.


So, I eventually switched to Byzantium, but the KDE Live couldn’t deal with LUKS, so I had to go an unorthodox route: install a bare minimal Debian Stable from Netinstall, and then add PureOS keychain, replace the sources.list, and make sure everything is dandy with some pinning.
Now I have a proper PureOS, but - and this is where I will invoke the rage of 3 distros at once -, I also added - with proper pinning well below PureOS - the repos of Kali and Parrot, including the contrib and non-free sections.

* running from stones, continuing the argument from a distance *

All three distros track Testing, but in a safer, slower way, so it’s not as risky as running a pure Testing. But I also need some packages that are not available from the PureOS software collection. Main is always from PureOS, per pinning, no way that anything can replace those packages.
Why don’t use Kali or Parrot then? Because they still have some quirks that are focused on pentesting, while PureOS is focused on regular usage - but with some hardening included.

So, I have the best of 3 worlds. But otherwise, the selection of packages from Kali or Parrot are very minimal. I have not encountered dependency conflicts so far with anything that I need.

1 Like

Unfortunately these two are still blocked.

Another package appeared today that is not upgradable due to a dependency version conflict with systemd: https://software.pureos.net/package/bin/byzantium/netplan.io

Another uninstallable package appeared, gnome-control-center
(see PureOS Byzantine missing settings/gnome-control-center for report)

Edit: gnome-contacts is also affected (though supposedly less criical).

And this is especially annoying, because you cannot edit anything (in a GUI) regarding system settings (VPN, bluetooth, etc.)

I’ve added deb http://ftp.debian.org/debian testing main contrib into sources.list for fixing the issue.

I have actually moved away from PureOS altogether with these persisting issues. Happy Archer now :slight_smile:

1 Like

Can’t say I blame you. I’m pretty patient, but it’s more than a month later and none of the conflicts I’ve mentioned above have been resolved. Neither has libflashrom1 been ported yet.
I wonder what is the blocker. If it’s lack of time on Purism’s side, it’s probably wise to switch to a distribution with a larger team behind it.

I’m no expert but I can see that Maintainer of libflashrom1 is Debian EFI, same as fwupd. Perhaps you want to check if fwupd package is installed (almost sure) and perhaps consider to remove it (temporarily).

Or try (on your own risk) with dpkg -i Filename: pool/main/f/fwupd/fwupd_1.3.11-1_amd64.deb and Filename: pool/main/f/flashrom/libflashrom1_1.2-5_amd64.deb, rest of dependent packages for “your byzantium” you need to find yourself.

IMO, this sort of compatibility issue (preventive and not to play around) with PureOS might be understood (just understood, not solved from someone that is not PureOS maintainer) if put in context of:

1 Like

It’s ported now :slight_smile:

Both packages are now available :slight_smile:

1 Like

I use Plasma, where I do not have this problems.

1 Like

Brand new PureOS Byzantium GNOME and PLASMA live hybrid images are available as of today.

EDIT: Thank you PureOS Team! To me it looks like that Librem 14, version 1, will be great laptop (in long terms :face_with_monocle:).

1 Like

Awesome! Yes looks much better now.