Pureos rolling release


#61

Ping works fine! FWIW it downloaded about 1500 other packages successfully Just not the ones in the error message. It looks like the package versions actually on the server mismatch the ones in the apt metadata.


#62

FWIW it looks like this problem was solved, or solved itself. I just re-tried and was successful in upgrading amber to byzantium on my Librem15v4. First experience is that rendering and screen updates feel faster, probably due to the new Mesa graphics drivers.


#63

Operating system: pureos Byzantium
Problem:
Did an update today and after I turn on my system instead of the login screen I get
Oh no! Something has gone wrong.
A problem has occured and the system can’t recover. Please contact a system administrator.
What I do after that:
•Ctrl+Alt+F2
•login
•sudo startx
• display shows
Oh no! Something has gone wrong.
A problem has occured and the system can’t recover. Please contact a system administrator.
With an option to logout below.
• I click logout.
•The XKEYBOARD keymap compiler (xkbcomp) reports:
Internal error: Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server
xinit: connection to the xserver lost


Gnomeshell crashes after update from 25/26th of april - byzantium
#64

I have the same on a Byzantium machine in Virtualbox. Are you also running your machine in Virtualbox, or is it non-virtual? (I have no solution, sorry).


#65

@Linuxnoob I have it even worse in Virtualbox - if I switch to another VT I only get the message

A start job is running for Hold until boot process finishes up (2min 30s / no limit)

So, I cannot even get a login prompt.


#66

I am not using a virtual box. I am using it on a desktop.


#67

I have the same problem. :dizzy_face: I hope someone can share a solution soon :pray:


#68

Gnome 3.36 had broken Debian (testing) a week ago but it was solved in an update next day.
Try to update from the comand line again.


#69

I tried updating, but it didn’t help. However, I have 8 packages being kept back:
gir
libnautilus-extension
libpango
libpangocairo
libpangoft
libpangoxft
nautilus
nautilus-data


#70

Try sudo apt full-upgrade but don’t do it just take a picture of the output and show it here or write it down.

The problem is that Debian people update some packages to gnome 3.36 but they left some dependencies without updating but I don’t remember wich ones, maybe gir…


#71

I get this:

Thanks for your help!


#72

If you upgrade like tht you will remove etcher from the system that’s why is not doing it, you can give it a try and hope for the best by I think purism team didn’t fix the broken packages yet.

Anyway it can be fixed using Debian testing repos on your own risk just let me know if you want to and I’ll write down how to do it.


#73

I full-upgraded, but unfortunately the problem is still there.
Is it risky to switch to Debian repos? Can (and actually should) I just switch back at a later point? I think I’ll try it, since it’s my only hope at this moment. :smiley:


#74

It’s just upgrade gnome-shell and dependencies from Debian unstable and then remove this repo you will be using pureos byzantium repos after this, I did it from Debian testing to unstable.

Do you know how to add repositories from terminal? I’m on the phone right know and takes a while to type this down.

PS. I just though that Debian testing is fixed now maybe it’s better install that gnome-shell or speak with PureOs team because they should update this packages


#75

I don’t know, but I can look for explanations myself later and let you know if I have problems. :slight_smile:

Edit:
So I changed the repository to deb http://ftp.debian.org/debian testing main contrib non-free.
Now I can boot and login, but the shell won’t open any software. Nothing will show up. Do I have to update gnome-shell still? Or did I miss something else? Already tried updating and upgrading through Ctrl + Alt + F3, but that didn’t help.


#76

Same problem here. After update i cant get x to start.
Also: i cant log in on the non X side. Have my authentication configured such that it requires a yubikey. The yubikey never lights up.
Typing my password in plain text into the login field to check if the keyboard setup is correct shows me the characters ‘A turn into ~A and an invert exclamation mark. Apologies for the strange typing, but im on my tablet.
Any help would be most appreciated.
By the way: my drive is encrypted with gpg and a librem key, on the recovery shell it asks me for a password and not for the pin, woudl this be my gpg password?


#77

I think I found the problem
Gnome shell is unable to update in the Byzantium repo
https://software.pureos.net/package/excuses/8390d15e-bf5a-4b6e-8843-be2a876591d5


#78

@Linuxnoob I just tried upgrading gnome-shell to the version in Debian - and it worked just fine - Thanks! I had to upgrade quite some packages though.


#79

So my main problem now is:
How can i update gnome. Meaning: how can i fix my login / yubikey problem or how can i mount my gpg encrypted luks main drive on a usb bootable linux to deactivate the pam yubikey enforcement


#80

I did this also - but it was way over my head. It took me 5 hours to finish it and reboot into PureOs (now welcoming screen says Debian 10)

It would be great if the devs would fix this issue soon in byzantium so that I can enable the byzantium repo again.

But I have to say, it’s an amazing feeling having accomplished the task and fixed the problem. :grin:

Hints for others: Chroot, decrypt LVM-Containers and you need at least another PC from which you can prepare a bootable PureOs USB stick and lookup the steps.

Gnome-Shell 3.36 looks really nice though.