Right-click (2 finger click) on trackpad not working, others experience this?

I’ve not overwritten the Purism installation that came on my Librem13, but my trackpad’s right-click stopped working. I’m guessing it has something to do with a apt-get update/dist-upgrade, but I was careful to look for diffs/conflicts presented to me for configs (and I’m still booting from Purism’s kernel).

Has anyone else experienced right-click stop working? That is: two-finger click on track pad. (I have tap-to-click disabled).

(picking up discussion left off in other thread)

Note: I now cannot get any response from my trackpad at all (but I CAN use my trackpad inside of lightdm).

Tailing a bunch of logs, nothing interesting happens when I interact with my trackpad (syslog used to print out a lot of lots when I used my trackpad):
tail -F /var/log/{dmesg,syslog,udev,kern.log}

Try installing and booting from Debian kernel that is newer compared to ours and report if it solves (or not the issues)

Hi Zlatan, issue not resolved, but get syslog sice updating repo URLs…

<b>changes</b>: Since adding the newer .net TLD repo URLs you provided, I now get /var/log/syslog output when I touch my trackpad.

<b>same</b>: still no movement of mouse or {left,right,double}-click interactions anywhere:

  • ran apt-get update && apt-get upgrade && apt-get dist-upgrade && init 6 <i>(no errors, no notes about Xconfig or anything i thought was worrisome)</i>
  • booted on 4.2.3purism-rc2: syslog output when touching trackpad, but no xev output
  • booted on 4.3.0-1-amd64: no syslog output at all (and no xev output)
  • for each kernel boot, tested both gnome3, purism’s default cinnamon install <i>(same behavior in both)</i>

can you look at output of:

cat /proc/bus/input/devices

and see if anywhere says Touchpad. If not it usually means kernel or xorg bug (in this case probably xorg). Notice that this should be all resolved once our driver hits linux mainline kernel.

In the meantime if you are brave you can try:

which already contains changes we are pushing upstream.

Right-click also failed for me on the Debian Stretch 4.3.0-1-amd64 kernel (though it worked just fine for me on the 4.2.3purism-rc2 kernel that shipped with my Librem 13).

I can confirm that the DKMS module Zlatan suggests works, although I had to fix the version number in a couple of files (the version was updated to “0.2” in several files, but they missed a couple of critical spots), so I’ve submitted a pull request:

Hi Allison,

nice to see you here. :slight_smile:

So Debian kernel doesn’t have that driver as we are still mainlining it (submitted, should be in linux kernel 4.6)

Richard is our guy working on it - https://github.com/pospeselr/linux-purism

Allison, thanks for the patch–I got an request from the Qubes team to increment the version when I updated the touchpad driver to reflect the new improvements Richard introduced and I missed a couple of places.

The good news is that Qubes is already packaging the DKMS module as an RPM in their 3.1 unstable repository for now and the driver overall has ditched the hardware’s internal notions of multi-touch scroll and you can use regular touchpad configuration tools now to enable/disable tap-to-click, disabling the mouse when you type, two-finger scroll versus side scroll and so on.

Hi Zlatan,

Can you specify completely the location of an iso image/install method/repository set which you know from recent experience will result in a working touchpad on a librem 13?

My device arrived last week. The touchpad worked in the installer just fine, but not in the resulting installed system. After that it didn’t work in the installer any more, either. After reinstalling several times, pointing /etc/apt/sources.list to the purism repos and updating/upgrading got me nothing, except: on one occasion the pad started to work…not very well, but marginally usable. Then after the next reboot it stopped again and hasn’t worked since.

I’ve also tried downloading the iso image for PureOS 2, but it installs with an apparently incorrect sources.list in /etc/apt. About the time I tried to point it to your repos was when your domain went down for most of the weekend.

So…then I tried installing Fedora and building Kyle’s driver. But dkms seems to be broken in Fedora. Eventually I got the module built, signed, and installed manually, only to discover that the Fedora kernels build the mainline psmouse driver into the kernel rather than as a module–so the byd driver won’t load due to the conflict. I’ll have to do a full kernel rebuild to get around that and run into the next dead end.

Unless you happen to know something that works?

My trackpad also just stopped working (and so left my Librem at home again today). No matter which kernel I boot from, I don’t get any /var/log/syslog output when I touch the trackpad (which used to indicate something was going right). When I say “no matter which kernel” I mean:

OK, I’ve done a Fedora kernel rebuild with the stock psmouse.ko getting replaced by
Kyle’s BYD driver. In proc/bus/input/devices I now see:

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name=“ImPS/2 BYD TouchPad”
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input16
U: Uniq=
H: Handlers=mouse1 event13
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103

Module insertion produces this in the system log:

Mar 7 18:39:38 newtoy kernel: input: ImPS/2 BYD TouchPad as /devices/platform/i8042/serio1/input/input20

Well, that’s all distinctly better. But I’m still not getting any action from the
touchpad. No tap to click, no cursor movement. It’s dead to the world.

Unfortunately this kernel doesn’t have an evbug module, I didn’t think to put
that in the build config. But then, I wasn’t seeing any events from the pad
with the purism kernels either.

The way this pad worked in the first installer, then became erratic, then stopped
altogether makes me wonder if it’s a hardware problem.

Zlatan, thoughts?

I see this topic is old, but i have just installed PureOS (i previously had Ubuntu on my Librem), and the double tap several times doesn’t right click (few times it does), and i cannot scroll with 2 fingers. It’s the latest PureOS which i have downloaded last week.
I also had problems with Ubuntu, the cursor was sticking in the up-right corner and only moved out after several tries, and the problem persists with PureOS (although more sparse).
I’m starting to wonder if I have problematic hardware (the trackpad).

1 Like

What Librem revision do you have? If this is revision with byd touchpad, try with this:

1 Like

Sorry for the delay, I’ve been traveling. I’m at home and will test and answer faster now.

patata@librem13:~$ sudo echo -n “byd” > /sys/bus/serio/devices/serio1/protocol to /etc/rc.local. cat /etc/rc.local
bash: /sys/bus/serio/devices/serio1/protocol: Permission denied.

I’ve bought my librem in April’16 so it should probably be the first revision?
The multi-touch has been working for a while but not anymore.

Check the file /etc/rc.local (you can view it in a text editor) to see if your echo command succeeded (it seems it did) and just restart.

Before restart make the script executable (chmod + /etc/rc.local)