Setting default browser?

I have a problem with my installation of PureOS where the system does not seem to know what to do with web links.

Links to websites in my Thunderbird emails are clickable, but nothing happens when I click on them. I have to manually copy and paste the links to the browser.

In similar way, my RSS reader Newsboat does not open links like it should. The original configuration of Newsboat had “browser open” in the config file, which seems like it was trying to use the “open” command to open the links.

My guess is that some OS level setting that registers web links as being handled by a browser isn’t set. How can I fix that? Also, is it intentionally left this way? One would think that a clean install of PureOS would know how to open web links.

Thanks in advance for any help.

Hi, normally you can (re)set this in the Control Center’s “Details” section, in the “Default applications” sub-section.

The setting is correct there, so something else must be off.

It’s apparmor. Add this to /etc/apparmor.d/local/usr.bin.thunderbird :

/usr/lib/purebrowser/purebrowser mixr,

Then “sudo apparmor_parser -r /etc/apparmor.d/usr.bin.thunderbird”

You’ll need to do something similar for Newsboat.

1 Like

Interesting… if the issue persists and it is a bug, could you report a bug on (and that way you can subscribe to it and get notifications about the fix, etc.)?

The issue does not persist after adding the line to apparmor’s rules for Thunderbird, so is it a bug or is it a configuration issue? I’ll report a bug because I think PureOS should ship with this enabled for Thunderbird and PureBrowser, both of which are included in the PureOS release. But there are countless other browsers that a user could install, and it’s not reasonable to expect apparmor’s default configuration to support all of them unless there’s a generic way to tell apparmor to allow links in Thunderbird to be displayed on the default browser, whatever that might be.

I keep bumping into apparmor’s protection, and I’ve learned to look there first when something that should work doesn’t. :smiley:

1 Like

Reported on tracker:

Tweaking apparmor’s settings fixed the issue for Thunderbird.

As for Newsboat, the default configuration tried to open the link with “open”, which does not work. Changing the configuration to use Purebrowser directly fixed that (

Aand it broke in a whole new way. Now apparmor can’t start properly because of “profile thunderbird: has merged rule /usr/lib/purebrowser/purebrowser with conflicting x modifiers”. This caused Newsboat to go into a really weird state where it dumped a lot of debug data in the terminal instead rendering the UI.

Removing the rule added realier fixed it. Links in Thunderbird still work, and now Newsboat does, too.