[SOLVED] Cannot Make Installation USB

I’m currently running Ubuntu Bionic on my Asus Zenbook and no matter what I do, I can’t make a liveusb of PureOS; I’ve used Etcher (as suggested in the installation directions), dd from cli, and unetbootin. I can make a liveusb of any other distro and run it fine, but whenever I try and put PureOS on the usb, it’s not even recognized by my laptop.



When using gmrl-rescueboot, I’m greeted with “error: file `/vmlinuz-4.16.0-1-amd64’ not found.”

Out of curiosity, have you tried Debian? PureOS is mostly based on Debian, so it would be interesting to see if Debian works or not.

Debian (stable and testing), Manjaro, the latest Fedora, ElementaryOS beta, and Ubuntu Bionic; all go on the usb fine and boot.

Hmm, ok. I was wondering if it was some sort of SecureBoot/UEFI problem, but if Debian and Fedora work, then it seems unlikely. I don’t think I can offer much help, then.

Hopefully someone else in the forums or Purism support will know more.

Yes, it is UEFI boot issue, PureOS ISO does not boots in UEFI mode, you can try changing to legacy mode and it should work.

here is another thread : PureOS ISO (USB) unavailable for boot (EFI) on Mac OS X


I saw that link, but thought it didn’t apply… turns out I only thought I had secure boot disabled; Asus’s BIOS calls it CMS and CMS must be enabled for secure boot to be disabled. Completely logical.

Thanks for all the help… this is solved.

you might find this thread interesting.