[SOLVED] How to get listed hub work with L5?

I bought and tried to test “i-tec USB-C 4K Mini Docking Station PD/Data” which is listed here and tried it on my laptop so I could display my L5 on the screen but the laptop didn’t seem to recognize it.

Now I’d like to test this hub with a monitor which has DP/HDMI but I would need an adapter for the hub its usb-c, like this usb-c female to HDMI male, would it work?

EDIT: the usb-c cable on the back goes to the phone to get it work.

No, you should attach the display to the hub directly using a HDMI cable.

nothing comes up under settings->display…also, no video output on monitor.

Do you see anything in the logs if you run this:

sudo dmesg

yes, it says

usb 4-0:1.0: USB hub found

usb 4-0:1.0: 1 port detected
usb usb4-port1: config error!

in one of the few last lines for the whole lenghty output.
this while having the HUB used like this…not sure if the usb-c in the back is needed to connect somewhere in order to make the whole HUB working.

I have no idea. You can file an issue in the kernel. Keep in mind that the community wiki is not maintained by us, perhaps @amosbatto can offer hints on how the device was tested.

EDIT: did you try connecting the cable that’s coming out of the hub to the phone? This is what most hubs I’ve seen expect.

If someone reports something working on a Purism forum or Reddit forum, then I add a link in the table to the forum post where it was reported, so people can ask the original reporter. In this case, see: [MyL5] Librem 5 and HDMI

However, others have edited the “Tested Accessories” page and they haven’t always identified who did the testing. I think that we should add a “Who Tested” column to the table, so people will know who to contact if they have questions.

I did git blame, but that’s effortful :slight_smile:

If its the C31MINIDOCK4KPD, then you just have to connect the cable which is integrated in the hub to the Librem5.

And everything you want to connect to the ports in the hub.

I still use it.