Time to flash is now - but how?

PureOS, Pop-OS, Ubuntu, Windows 11.

Ubuntu, POP and Windows 11 hasn’t been used in a long time (pre-COVID even)

1 Like

Which Ubuntu version?

1 Like

20.04.2 LTS (20.04)

I booted Ubuntu from boot menu, added login Pword and it froze. I waited 5 minutes and for fun, pressed CTRL-ALT-DELETE and got a black screen.
A few minutes later, the desktop appeared and offers a “new version is available”
So, on your say-so, I’ll hit the Upgrade button for Ubuntu.

1 Like

I would upgrade it, unless you’re worried about losing or corrupting some package or personal data inside the current Ubuntu install. (Although probably nothing bad will happen anyway.)

It’s recommended to back up your data just in case, anyway. There should be a backup tool in Ubuntu that makes it easy.

The upgrade will take a while to complete.

Alternatively, you could first run apt search uuu to see if the uuu package is in the Ubuntu 20.04 repo. If it’s found, you can probably just do the L5 flashing first, then upgrade later. If uuu is not found, then the upgrade will need to be done first.

Or upgrade PureOS instead, and do the flash there. :wink:

1 Like

First, I don’t care about the data. Everything pertinent has already been backed up to external drive, and I’d prefer to flash phone w/ upgraded Pure from PureOS. Hope keep it ll in the same family.
So, off to upgrade Pure on Host so Byzantium is on it.
I’ll wait to hear back from irvinewade whether I should use the process described in my post above (


Yes, you do. :slight_smile:

That is the reality of IT. It keeps on changing and you have to invest time and effort (sometimes even $$) in maintaining it. Even I would agree that this is sometimes a pain in the proverbial. It isn’t really different from your car or your house though.

However in this case there are also security issues in play. I would guess that updates are no longer being provided by Purism for amber so your system is at risk if any unpatched security bugs start to be exploited in the wild.

You should treat it as a priority to run byzantium instead of amber.

I am probably not the best person to ask because I certainly don’t have any Microsoft Windows at all and I am not typically doing dual-booting even within the Linux world. I also don’t have any PureOS on desktop / laptop (only on my phone, which has some pertinent differences in system administration).

Where I do have separate booting, I do use an external disk - because it is safer and cleaner. (So I’m not using the GRUB menu to choose what to boot, I am using the BIOS’s boot disk menu.)

Digressing slightly, I tend to think: one purpose, one computer, one operating system (the “best” for the purpose) - and “less is more”. Having three extra, unmaintained operating systems is not helpful. In this case, I would keep the Windows and I would pare the Linuxes back to your choice of one - but because of the presence of Microsoft Windows, I can’t tell you how to achieve that.

My generic advice would be: whatever you do, back it up first (i.e. image the disk to external media) so that if something goes wrong, you can get back to where you were.

If it were my computer, I would probably try to:

  • back the whole internal disk up to external media
  • blow everything away on the internal disk
  • reinstall Windows on a new external drive (assuming that you have original Windows installation media)
  • put Windows in the cupboard
  • install the latest release of your choice of one Linux distro on the internal disk
  • restore documents etc. from the original backup

Regardless, I would recommend holding off on any Ubuntu upgrade just for the moment - because Ubuntu 24.04 LTS will be along in a few weeks. (That said, the upgrade path from 22.04 LTS to 24.04 LTS won’t appear for some further months and I’m not even sure about an upgrade from 20.04 LTS to 24.04 LTS.) Note that there is slightly less priority for upgrading Ubuntu because 20.04 LTS is still well within its support period. Security and other fixes would still be coming through (provided that you boot it enough).

It isn’t. Self-citation :wink:: Building uuu and Jumpdrive · Wiki · Librem5 / Librem 5 Community Wiki · GitLab

Hence, in order to use the existing disk, at least one of PureOS or Ubuntu will have to be upgraded or replaced.

… may be to download the latest Ubuntu iso, make a bootable flash drive from it, boot that in order to carry out the task of reflashing your phone … then come back to the needed maintenance on the desktop / laptop.


I’ve been maintaining mine since 1982 or 81 - memory isn’t great.

I meant, it’s going to be total install Pure on a formatted Hdd. Load up all the updates and so on.

NOTE: So there is no misunderstanding, the phone has Byzantium, the Host has Amber. I need to upgrade PureOS on the Host.

That’s what I’m trying to get done. But, there is that error I already detailed earlier where the command to reboot is not in Amber, but is in Byz so I want to get Byz version installed - to Hades with all the other O’s om the system. Ignore that info please.

1 Like

uuu is not in the Ubuntu 20.04 repo, but it can be installed as a snap. The snap package is universal-update-utility and is version 1.5.21. The person who uploaded it has login nxpfrank and since they are not a “star” or otherwise marked as official, it’s not clear it should be trusted. On the other hand, the following issue on the official github site would suggest it should be safe: Intent to package: Snaps are universal Linux packages · Issue #221 · nxp-imx/mfgtools · GitHub

[Edit: It appears that uuu is in 22.04. Ubuntu – Details of package uuu in jammy ]


Yep, I got that. The host needs to run byzantium.

I’m not commenting further on that for all the reasons that I gave. I indicated what I would do with your computer if it were mine. And I indicated what I think is the path of least resistance in order to get the phone reflashed.

1 Like

I know we do not orbit the same language.


'sources.list" is a “read only” file!
So I’ll search out how to change the read only files to read/write and back again.
Then try again…

1 Like

Run this in the terminal:
sudo nano /etc/apt/sources.list


:+1: :clap: Woohoo!!!
Thank you! Once the permissions changed, I could continue changing amber to byzantium in the “sources.list” file.
It’s still cranking away upgrading to byzantium - hopefully without any errors. Then I can flash the phone maybe.

BTW, for posterity sake, I tried the CHMOD (something I remembered from days gone by) and the system had hissy-fits. Your one liner solution worked so much better.
May you be gifted with 10 cases of your favourite drinks.
All went without noticeable errors. The upgrade stopped at:

Processing triggers for libc-bin (2.28-10+deb10u2) …

I think it’s time to reboot. It doesn’t show anything after that last line and the progress bar hit 100%. I gave it 15 minutes AFTER the last line and had HDD settled down.

As Curly would say “It woiked!”
Shows it’s Byzantium now, not Amber.
Now to try to flash the phone again.


Strong recommendation: Don’t do that.

If a file has restricted permissions then use sudo to access the file as root thereby bypassing the restricted permissions - rather than trying to change the permissions with chmod.

In quite a few cases, Linux will explicitly detect when a file has looser permissions than it should - and actually stop the file from working. However I expect there are many cases where no such check is made and you will just end up with an insecure system.


Yeah. Well, doesn’t matter. I’m sure post 16 was well intended, and the adventure of updating Amber to Byzantium was exciting; sadly, it was all a usual waste of time.

The desktop showed everything that was being done to phone, all 4403 lines.

It’s like reading a 500 page mystery novel only to find the last page is missing.

I asked support@ here what they’d charge if I sent it back sans battery and they fix it and send it back with the correct version of OS properly installed along with a battery. That was weeks ago.

Am not a happy camper. Rightly so.


I assume that you are out of steam, at least for the moment. Because you haven’t given us much to go on to resolve whatever might have gone wrong with the reflash if indeed anything has gone wrong.

@JCS Are you able to escalate to get an answer?

1 Like

Reminder that my post #16 was just a restating of @david.hamner 's video and transcript. :wink:

Upgrading your computer to byzantium was definitely worthwhile, though.


Sharon, which version of uuu do you have, now that you’ve upgraded?

1 Like

8 posts were split to a new topic: The travails of updating and reflashing

I don’t know what to tell you except when it finished the last few lines were:

> Processing triggers for dbus (1.12.28-0+deb11u1) ...
> Processing triggers for libc-bin (2.28-10+deb10u2) ...
> pure1@pure-pc:/etc/apt$

Nothing telling what else to do, so I waited and assume it was done.

  1. Checked phone Chat, Picks and Docs and all were still there.

  2. High score in 2048 - still there.

  3. at lines 3724 and 3725 were:
    A reboot is required to replace the running dbus-daemon.
    Please reboot the system when convenient.

Lines went by so fast, I never saw some of them…

In log, I count 16 noted errors. But line 4352 says:

Installation finished. No error reported.

…and 15 warnings.

About the support@ - my friend tells me he forwarded a email to me while managing my mail for while I was in hospital. I can’t find it. But said there was a reply from support wanting me to tell them. I’m trying to get him to send it again.

What a world, what a world… I’m melting.

1 Like