To keep our librems up-to-date should we all be following the forum and updating our devices ourselves?


#41

Excellent information, thank you again for your help, @kakaroto!

:smile:


#42

Ok so I tried to boot from the stick but when I turn on the laptop and hit F2 or hold it the screen changes from its regular loading of PureOS to all black with a few lines at the top, one of which says to visit a particular debian link on wiki for missing firmware.

That happens consistently no matter how many times I try to restart while the USB stick is in our out of the port. If I shut down in the middle of starting it and then start it up again, a special page appears automatically prompting me to run the PureOS version or to run a memory test etc. If I access the advanced options therein, no option is given to access the USB stick either.

Also, if I try to access the same menu with no USB stick plugged in but only plug it in when the menu is already loaded, the USB stick is also not detected.

I also tried pressing F1 instaed of F2 and it also doesn’t do anything. Should I for example press it juts one time intead of holding it and or do so with the stick in or out or?

Thank you, sorry for the hassle, I thought it’d be as easy as simply sticking in the USB and hitting F2 and then loading things from there.

I’d assume the problem is the USB stick itself but I followed your direction on Etcher and the USB stick I used worked and plus the BIOS menu doesn’t seem to even be loading when I hit or hold down F2.


#43

When you boot, when you see the purism logo for a second before it tries to boot your OS, it should say “ESC->Boot menu” at the bottom…
So, press the ESC key, not F2 :slight_smile: (I also mentioned it before that it should be the ESC key by the way)


#44

Ah okay, I’m sorry I missed that. Thank you :smile:

I’ll try it again now.


#45

@kakaroto,

Ok so you were right, it was just that easy. The thing is now, I am in the Qubes installation setup and in spite of not having installed anything on the SSD drive that came with the Librem, which is over 112GiB, when I select it as the installation destination, it seems to think that there is basically no space on it left. Do I need to “delete all” and thus the PureOS in order to free up the space on the drive? As far as I can tell the PureOS should not at all take up some 112 GiB and so maybe it’s just the fact that the drive is not the right format or something? I have no idea.

Here is a screen shot to show you where I’m at:


#46

I’d suggest you either use a different hard drive, or to completely erase your existing one (and lose PureOS).
Yes, you aren’t using the full 112GB of your SSD, but your SSD is still partitioned to use the full 112GB. I suggest you read up on how partitions work and why it doesn’t work the way you think it does.