Traveling Experiences

$ nmcli conn edit <ID>
===| nmcli interactive connection editor |===

Editing existing '802-11-wireless' connection: '<ID>'

Type 'help' or '?' for available commands.
Type 'print' to show all the connection properties.
Type 'describe [<setting>.<prop>]' for detailed property description.

You may edit the following settings: connection, 802-11-wireless (wifi),
802-11-wireless-security (wifi-sec), 802-1x, ethtool, match, ipv4, ipv6, tc,
nmcli> describe

=== [band] ===
[NM property description]
802.11 frequency band of the network.  One of "a" for 5GHz 802.11a or "bg" for
2.4GHz 802.11.  This will lock associations to the Wi-Fi network to the
specific band, i.e. if "a" is specified, the device will not associate with the
same network in the 2.4GHz band even if the network's settings are compatible.
This setting depends on specific driver capability and may not work with all

(I only just figured out nmcli has the ability to describe things in this way.)

1 Like

@patch Out of curiosity, have you now made that setting and does it work? (where “work” means either “does what it says” or “solves your problem” or both)

Just as well I asked about the syntax because that is well um … non-obvious.

For the record, we are only grappling with the opposite situation i.e. same SSID used with each band.

Assuming that you (like me) use different SSIDs on each band, it looks as if you can set a preferred SSID and in my experience it will hold onto that SSID until it actually loses it (rather than jumping around based on highest signal strength) and for this particular problem if you set 2.4 GHz as preferred and you lose 2.4 GHz signal then it is very likely that you have also lost 5 GHz signal (unless you have more than one WAP and your WAPs have different configs) so it would “never” change band.

Back to the subject line but not to anyone in particular. I watch a youtuber by the moniker “Itchy Boots”. She rides her motorcycle through several countries. Currently she is in Botswana, having just left Namibia.

Every time she crosses a border she has to get a new SIM card.

Yes, I made the setting (bg).

In one test just now, I could not reproduce the problem I had before, but I can’t conclusively prove that that is because of the band setting.

Another way to attack this issue might be to implement 802.11r in the network, perhaps with 802.11k and perhaps with 802.11v, to encourage client devices to switch to stronger signals more readily. (Don’t ask me for details; I know not much more about these standards than you can learn from Wikipedia and your favourite search engine.)

I feel like I’ve derailed the thread a bit here. Sorry about that.

1 Like

If you go into Settings / WiFi then somewhere in there it shows you the band that it is using. That doesn’t prove anything either but, if both bands should have a strong signal i.e. you are right on top of the WAP, it should give you confidence that the setting is working.

Well, not really. As I said yesterday; it was using 2.4GHz when it was right on top of the WAP even before the setting was made. So, it really doesn’t prove anything if it’s on 2.4GHz right now!

Even so, probably worth a try if you find yourself with poor signal in a hotel with the same SSID for 2.4GHz and 5GHz.

That sounds like an interesting travelogue. I’ll take a look.

1 Like