Tweaks - activities menu

I’ve searched and seen a few posts on this already, but no real resolution. I tried enbling an extension and it has failed. I’d like to revert back to not having it, and in a post by mladen I saw a version of this dialog box that had “Remove” as an option, but mine does not. I’d like to turn off the option I tried to turn on, “Add a category based menu for applications”

You might want to try a different desktop environment. I fought with GNOME Shell for 2 years and just gave up on it, because I could never get it to do what I wanted.

If you want an interface like Windows 7, try Cinnamon:
sudo apt install cinnamon-desktop-environment

Thanks very much for the input. I definitely don’t want a Windows experience, just looking to restore the Activities menu.

The extensions are stored in ~/.local/share/gnome-shell/extensions of I’m not wrong, try removing the folder for that extension and hope for the best.
If not there is an app to exclusively manage extensions but I don’t remember its name and I’m not sure if it’s in PureOS already.

It seems like the web interface of offers the remove option for non-system extensions. Though I think you need a plugin for the website to work, which maybe you don’t want to have.

1 Like

This is how I do it. Through the extension site with a plugin.

Hi @temurphy68

For this to work you need the Gnome Shell Integration addon in Firefox:

But you can also remove an extension from the GNOME Software app store. (If you are using PureOS Amber).

But the issue you have may be caused if the package gnome-menus is not installed. As described here:

If that is the case, it can be solved by running the following command from terminal:

sudo apt install gnome-menus

And then after reboot, the Applications Menu extension should work (on PureOS Amber, the default version we ship with our laptops).

If you are using our testing verison (Byzantium), you might need to additionally install the extension: Hide Activities button:

To install that you can do it via firefox with the Firefox addon mentioned above

1 Like

Thank you all for the input. I will try your suggestions this evening.

I appreciate everyone’s contributions.

You may want to try that suggestion above with --reinstall, i.e.

sudo apt --reinstall install gnome-menus

I found when I originally did this, it solved the same issue you seem to be having. If memory serves, my Activities menu was also nuked by the error and that reinstall created a missing file that will get rid of that error triangle for Applications.

You can look here and follow the links if you need more information.

It was indeed that easy. Thanks to everyone for the feedback.

This is resolved (for me).