Urgent! The Librem5 does not start up since today's update on August 17, 2022

If you’re planning to reflash, I wouldn’t erase anything. The system is going to be written over.

In any case, you should ask Support to clarify. (I guess we’re talking about the boot sector?)

Purism said that I will be able to reboot if I erease these versions and I create a symlinks.

Ah, OK, then definitely ask them to clarify. But I assume they mean to delete anything with “5.something that is not 18” as a name.

1 Like

No, please don’t delete the grub folder. Cleanup of dtbs will be taken care of when you’ll finally be able to clean up by removing the packages they belong to I’d expect.

The problem is that you do not have a backup of your data and that it is hard for anybody here to take responsibility over the recovery.

If you’d have a backup you’d flash a new image and if it works install your applications. Then you’d get your home folder from your backup. That should recover your data. Anything missing? You’d search your backup.

So a complete innocent advice without any background knowledge of your folder structure and applications would be to copy all of your home folder before installing a new image and copying back the content of your home directory.

If the reason for the failure lies in your home directory (not very likely) you’ll hit the same error again.

Tilix say to me 5 bugs before I reflash (copyed/pasted in french down this email) :

  1. specify at least 1 package to check the construction dependencies

  2. Some package can’t be installed

  3. impossible to correct the problems of the packages

  4. no module named « tqdm » ;

  5. command not found

I) martin@Ephemere:~/librem5-flash-image$ sudo apt build-dep
E: Il faut spécifier au moins un paquet pour vérifier les dépendances de construction

II) martin@Ephemere:~/librem5-flash-image$ sudo apt build-dep .
Note, utilisation du répertoire . pour obtenir les dépendances de construction
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
builddeps:. : Dépend: debhelper-compat (= 13)
III) E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

IV) martin@Ephemere:~/librem5-flash-image$ sudo ./scripts/librem5-flash-image --udev
Traceback (most recent call last):
File “./scripts/librem5-flash-image”, line 20, in
import tqdm
ModuleNotFoundError: No module named ‘tqdm’

V) martin@Ephemere:~/librem5-flash-image$ $ ./scripts/librem5-flash-image
$: command not found

Which distro are you using? debhelper 13 is what’s in current Debian stable (bullseye).

Since you’re not actually building that package but just want to install its dependencies, as a quick workaround you may be able to move forward by editing debian/control file and removing debhelper-compat (= 13), line from it.

PureOS on my Librem 13. And I don’t know how editing and how removing

Another point : I copy the calendar.ic file of my Librem5 and paste it in home/local/share/evolution/calendar/system of my Librem 13 and nothing appear in the calendar of the computer… I work each day without my Librem5 and his calendar since this bug, impossible to know what I have to do… so, I must hate GAFAM very much (and love Purism) to sill refuse to take back an Android.

I try to install PureOS 10 with my USB drive but, when I restart the L13, I push ESC. He ask me to do my password on a blacksreen or the screen become blue and he ask me to choose on what Linux start (but I don’t see any 8.1 Go USB Flashdisk-USB disk anywhere).

The logo appear some second before he finish to boot, after I made my password. When I clic at this mpment, nothing happen…

When I see « Megatrend » I push F2 and there is a menu

In the menu I can choose « Boot »

In « Boot » there is an option « Boot override » Is it that?

I don’t see a USB 8.1 Go Flashdisk, but I see like USB 1000 (or something like that). I choose to boot on that USB…?

If you don’t have any other USB drives in, then yes.

One last question to reflash : When I write in the terminal :

Tilix say :
Could not find command-not-found database. Run ‘sudo apt update’ to populate it.
$: command not found

But I have done apt update and apt upgrade…

This is a bug in Debian, of which PureOS is a derivative of. I also had it on my Librem Minis.

As mentioned in this post, the consensus seems to be to just remove “command-not-found”.

I am a beginner and I wonder if deleting this file can have major consequences on the Librem5 in case of reflash. Can you reassure me?

I’ll try … (not for real) but as first please read and understand what is indeed written: “command not found”. While something not found within folder/directory where you are currently typing here related/correct command and move forward (while obsolete approach taken, besides wrong question asked):
cd /home/path-to-your-user-name/
cd to_the_chosen/related_script_extract_folder
Turn-on every HKS (disable related chips/cards)!
cd librem5-flash-image
ls -la
cd scripts
ls -la
uuu -lsusb

In short: adjust as necessary official or several other related links (search this Forum further for many related and quality tips … already and kindly written here for all …).


I’ve deleted the command-not-found utility on my Mini. What it is supposed to do (if it worked) is suggest similar commands if the command you typed in is not found.

Since I deleted it, now when I type a wrong command (one that doesn’t exist), I get this:

$ blug
bash: blug: command not found

Which is what I want :slight_smile:

TLDR - You can delete the command-not-found utility, and your system will run just fine.

1 Like

And to continue … command-not-found is a symptom not a cause.

Whether command-not-found is present or not, the system is complaining about a command that is not found - and that is what needs to be fixed. A command that is not found can be caused by

  • a user incorrectly typing a command, or
  • a user correctly typing a command but the package that provides that command is not installed.

Worse still, if the error is coming out of a shell script then there can be other causes e.g. the shell script could be erroneous in some way.

In this particular case, it would seem that the user fat-fingered the cut-and-paste i.e. the first explanation. There is a rogue dollar sign in the command, to wit:

martin@Ephemere:~/librem5-flash-image$ $ ./scripts/librem5-flash-image
$: command not found

(emphasised in bold)


Very correct (but not only in this particular case)! Because helping to each other is mainly about listening (not about driving one way street of some particular color) as otherwise we do have or:

At the same time/tone people that do not listen (learn from the historical facts, for example) are the ones that cause (not only for themselves but mostly for their neighbors and relatives):

In short, people do make wrong decisions (while blaming others for the wrong ones that they made earlier), even to the point that decision makers take them seriously and continue to make other people lives miserable without being responsible (not openly visible and certainly not admitted) for the consequences they’ve triggered:

$ in-the-name-of-love
bash: in-the-name-of-love: command not found

In the end, everything was solved thanks to all the advice given to me by @mladen jakovic. The only solution was to make a backup of Librem13, install Byzantium on this computer.

Then I was able to reflash the Librem5 following the instructions here https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Reflashing_the_Phone.html

Without Byzantium, it was totally impossible for me to apply these instructions. Thank you all for your help!