USB-C dock C13NANODOCKLANLP and power supply

That was basically my thought as well, thanks for emphasizing this! For example someone that I know recently received LLANO LIN-CC1007 6-in-1 docking station (closely related to Green Cell 7-in-one USB-C Hub from your initial post list) end every port within it worked out-of-the-box (5.10-sunxi64 kernel) with PinePhone. lsusb reads its chips like this:
ID 05e3:0749 Genesys Logic, Inc. SD Card Reader and Writer
ID 05e3:0610 Genesys Logic, Inc. Hub

Don’t know which chip it uses for HDMI output yet this docking station scales (to external monitor) resolution to 2560x1440 60Hz easily. This resolution works too:

And if someone interested (special feature), I like to confirm that it supports OTG function (uses phone’s battery, discharging mode), including read/write to USB 3.0 flash drives (works with monitor as well but probably not for long):

NOTE: For charging other device (Linux smartphone here) with this HUB please use 5V/2.4A charger and USB-A to USB-C cable only (this note is based on my short experiment as I forgot for a second that PinePhone doesn’t support PD charging)!

Hmm, meanwhile i tried another dock with negative results. From the logs, it was such a disaster including kernel oopses, that i reboot the phone. Thus 5.11 brings some improvements, but is not resistant enough, to cope well with every device. Additionally, the dock is clearly branded. I’ll plug it into my notebook next, and if only to get down to the usb-id.

That a dock works well with pine phone does not mean it would work with the L5. I had negative results with the dock sold with the pine phone. Chances are, that this might work now with the newer kernel, but i’ve not tested it yet.

Given, that there is such plethora of usb-c docks offered, it would be nice to have attribute at hand for a buyer to check. There’s none so far. It thought might help, to look at the particular driver, but there is only few hints i could make use of e.g. here or here. The last link at least gives some information about the user space. Unfortunately lsusb does not provide much help here, yet.

1 Like

I do not have Pine64 one so cannot follow how that docking station behaves. Anyway, Powersupply app (with currently using llano docking station in between) and /sys/class/typec/port0-partner supports_usb_power_delivery file states no (kernel and/or self/external devices in use related, as I’m just trying to understand this). Let me philosophically say that main device/kernel still have main word about this partnership, even if Linux drivers available (or when available), hope I understood your advice right. Of course I need to visit device folder too, but no time at the moment. Thanks for sharing link to port0-partner usable info! And, I’m sure that this link belongs here (to include page 9):

Let my paraphrase myself (yourself?): Linux kernel, main one, particular distro one, provides shaking hand to the external device (particular port chip) or it doesn’t, so simple is this (not to spend unnecessary time with the wrong external device, even when it carries sound price or most recent name). Further reading about “Alternate Mode device” …

Here is link (starting point only) where you/someone should be able to find further official and useful info:

0x4c35445000000200, hmm, looks familiar, its a firmware version, which i’ve already checked there.