USSD codes on the Librem 5

In that case you should create an issue. (However you will need an account for that first.)

For some reason 2G, 3G (Preferred) and 3G only don’t work. Setting the network mode to 2G, 3G establishes a 2G connection: I cannot send the USSD code anyway, but I can receive calls (big improvement).

Do you actually have 3G reception around?

1 Like

I would be surprised if not, but I cannot say, I’ve changed carrier few days ago … it may not have 3G coverage

Zoom way down to neighborhood level and observe the color of “3G” as per the legend:

I just learned that this carrier only rely on 4G or 2G


Edit: nperf isn’t detailed enough, it shows nothing in my area.

Ah, yes… I see Vodafone allegedly shut down 3G in January:

It may be that not enough users have reported 3G coverage there because most were on 4G, possibly.

You can also check:

but USSD codes should work with 2G, right?

They should; it’s just GSM technology, I think.

They don’t :disappointed:

Hi All,

i have a librem 5 usa model I’m using it here in ksa with mobily network i tried all modes 2g 3g 4g still no ussd codes works.

can someone please help? also would be grateful if someone provides installation instruction for


sudo apt install prepaid-manager-applet

1 Like

@dos thank you very much. however there is no option to run custom ussd codes .

is there any work around for this ? when i try to run *200# all i get is endless spinning.

the version of calls i have is 43.0

For what it’s worth, USSD codes work for me with my provider (in Poland) just fine. This sounds like some career incompatibility.

is there any other program to run ussd codes or a command that i can run to check ?

Is it *135# (my own number) working on your phone?

Unfortunately no, nothing works. just endless spinning

hi all,

i flashed postmarket os v22.06 on librem 5, i was able to get 4g internet and sms to work both sending and receiving. but no calls or ussd codes.

1 Like

hi all thanks to @joao.azevedo everything works (calls, ussd codes ) after upgrading the modem firmware .