Wifi and Bluetooth Have Never Worked

False Jail it is an OpenSource THING which makes sense if this FOSS-BLOB-Firmware is hosted in /lib/firmware directly, so an opensource user here could recommend a simple Command that would solve the whole problem without going to an useless False Jail. However there are True Jail but this is not the case right now.

1 Like

I’m in the United States, and I think government agencies are after everyone (not just little old me). The seller was a reseller, who didn’t know anything about these phones.

1 Like

In that case you could send it in to Purism for repair and get it sorted out properly.

1 Like

Might do that if it isn’t working after this; did the flash, followed the steps, solid red light, now I wait…
will it turn itself on? Am I supposed to turn it on after the the light is solid red? The steps are not entirely clear on this point.

1 Like

After reflashing Byzantium, the script should indicate success, the Librem 5 should turn solid green, then show the LUKS prompt. The default passphrase is 123456.


You may need to post some of the terminal output from the host computer (redacting anything that is sensitive). That way we can see whether the flash did succeed.

Provided that the flash finished, whether it succeeded or failed, it should be OK to reboot the phone. (And if it didn’t work, you can safely have as many attempts as you need.)

The question is though: Were you previously using the encrypted file system (requires a passphrase to be entered at boot before the login PIN) or the unencrypted (plain) file system? And which did you choose to reflash to?

1 Like

Okay, I would like some clarification on flashing steps please.
When the “./scripts/librem5-flash-image --stable” step is complete, how should I turn the phone off so that I might turn it back on while holding the volume up button? Previously, I turned the phone off via the drop down menu at the top, and then turned it on via the method described, but I found the phone would not turn on while I was holding the volume up button.

If I am unsuccessful after loading, and nothing is different when I turn it back on, do I have to download and flash everything all over again? It doesn’t seem to have took.

1 Like

Usually I turn off my Librem 5 USA using the drop down menu, but you can also force shut it off by holding the power button for over 5 seconds. If you are unable to enter flashing mode using the first method, follow the detailed instructions for the second method instead.

You don’t want to hold either volume up or volume down to reboot the phone after a flash.

The instructions say, for the procedure after a successful flash: Remove the USB C cable and hold down the power button for 15-18 seconds to reset the phone.

Yes and no. If you follow the default procedure then yes. If it looks as if you are going to have to do this a few too many times :slightly_frowning_face: and if your internet is slow then there are additional optional flags to the flashing script to expedite the process i.e. only download once.


Yeah, because it absolutely will not turn on if you’re holding volume up as the instructions indicate.

Each time I do the step “./scripts/librem5-flash-image --stable”, it insists on downloading it all over again, over 4G, which did gobble up my remaining data, but I was going to upgrade that anyways. It is, however, very slow; why does it not search for a temp file? I’m now downloading it again for the third time because of the volume up command. These instructions are confusing and incomplete IMHO. How exactly do I enter flashing mode after the download step (./scripts/librem5-flash-image --stable) is complete?

1 Like

Either of these two methods.

Just to confirm, you’re performing these commands on your Linux computer, right?

See if these more detailed, but simplified instructions help: Time to flash is now - but how? - #16 by amarok


I’m doing it on the phone itself. I have Mint on my laptop, but I am not doing it via the laptop.

1 Like

OK, there’s your problem. You have to use the computer to download and then flash the OS onto the phone.

If you’re running Mint 21.x, you should be good to go. If the package called uuu is available in the Software Manager, or is found with apt search uuu in the terminal, then you’re ready to start.


Because you implicitly told it to delete the temp file (which I assume it did).

./scripts/librem5-flash-image --help

You can download once by using the options --skip-cleanup --skip-flash --dir DIR

and then flash as many times as you want by using the options
--skip-cleanup --skip-download --dir DIR

where DIR is a suitable directory to contain the temp file e.g. ~/tmp presuming that you create such a subdirectory (tmp) of your home directory (~)

and in either case in addition to whatever other options you choose e.g. --stable.

If it didn’t delete the temp file by default, I’m sure some people would complain that it is tying up 5 GB of disk space. :slightly_frowning_face:

However you are dead in the water if you try to do this on the phone itself. I draw your attention to, from above:

In order to reflash you don’t need working WiFi on the phone (or indeed any internet at all on the phone). You do however need a desktop / laptop (or at a stretch other options) that is running Linux and which does have a working internet connection.

but I guess I can see that that wasn’t clear enough.

The official instructions just say:

This guide describes how to reflash the system image on your Librem 5 phone from a workstation

and maybe that doesn’t highlight what “workstation” means and what it implies.


Okay, I have successfully reflashed my Librem 5, but the Wifi and Bluetooth still do not show up; flipping the switches doesn’t effect it, bluetooth software ‘switch’ remains greyed out, and the Wifi settings in menu do not populate or appear at all. I guess I will contact support now. Thank you all for your help.

1 Like

After reflashing the Librem 5, if you have not done so already, you should reflash the firmware jail.

Otherwise, keep us informed if Purism support are able to resolve your issue. You will likely need to send in your Librem 5 for an RMA.


Or at least attempt to determine whether it already exists at all.

The system log will probably be indicating success or failure with loading the firmware from the jail to the card.

1 Like


So, as you knowledgeable and helpful fellows noted above, I did need to reflash the Firmware Jail using the instructions roughly noted here:

However, on the step wherein the phone will say: “Wait for Known USB Device Appear…” my phone would not be recognized or the flash would fail. This happened numerous times, and I gave up. I had contacted Purism Customer Support, and João Azevedo was eventually able to get back to me after our initial email where he originally advised the same as you all did above (flash the firmware jail), he then advised that it might be a udev rules issue, and apparently, I had to do that again for each type of firmware flash, just as Frankly Flawless advised for the initial firmware flash above; it is NOT included in the instructions shown at the above link!

João directed me to follow these steps:

git clone Librem5 / librem5-flash-image · GitLab

The librem5-flash-image directory will be created. Make this directory
the current directory:

cd librem5-flash-image

Install the udev rules: sudo ./scripts/librem5-flash-image --udev

Then repeat the previous steps, and use the a USB-A to C cable for this.

It now works! I have both Bluetooth and Wifi, and have spent several days connecting it to various devices to test it. I am able to transfer files over bluetooth (I transferred some MP3s), which is slow, but at least that works, and the Wifi seems to work A-OK. The Bluetooth does not stream music very well on my truck’s stereo (5-6 seconds of clear, followed by 5-6 seconds of static, consistently), but I’m sure that’s a setting or something that I need to figure out. At least the phone actually works now, inspite of its numerous functionality quirks. Thank you all for your help with this matter.


To be honest I have never bothered with the udev rules. However you have to do one or other of the following:

  • sudo ... --udev as a one-off
  • sudo when you do an actual flash or any similar use of the phone’s Serial Download mode (flash mode).

I always do the latter and it has always worked for me.

The above instructions may be assuming that most people have already previously reflashed the actual phone and followed those instructions and hence already set up the udev rules.

Yes. Bluetooth is an order or orders of magnitude slower than WiFi.

The problem with streaming audio via Bluetooth is well-known but inconsistent (and has been discussed in various other topics in the forum).

1 Like