"You are not authorized to execute that function"

I am on my second day of experiencing PureOs.
I went to gnu.org website, where I found PureOs listed with some other distributions.
I downloaded it, and flashed it on to a 16G usb stick, and rhen set about installing it on my Corei3 pc with 4GB ram. The first installation failed miserably due to there not being enough free ram.
So today I bought 16GB of ram, and tried again. It installed successfully.
So the next step is looking at what software was installed by default, and getting the software that I want on it. Up pops a window, saying ‘Updates Available’, so I click on it, and another window appears, listing some available updates. There is a button labeled ‘Update All’. I click it, then another window appears, with a message saying “You are not authorized to execute that function”.
There is also a ‘Discover Software’ feature in PureOs. I clicked on that, and got a window showing categories of software, and a list of packages. One of which was GIMP, which I would like installed.
So I click on the install button, and yet again I see a window containing the message “You are not authorized to execute that function”.
I was logged in as the System Administrator. How can a System Administrator not be authorized to install, or update software packages?
Why are the ‘Discover Software’ and ‘Updates Available’ features there at all, if I am not allowed to use them?
There is no explanation on screen for how a System Administrator can acquire the authority to execute these functions.
PS My previous experience is with several releases of Suse Linux, which were very good.

1 Like

What happens if you try doing the updates at the Terminal?

sudo apt update
sudo apt upgrade

Maybe that will give you an error message as to why you, as an administrator, cannot install the updates.

1 Like

Thanks leetaur, for your comment.
I think I have sussed what’s going on.
Logging in as ‘System Administrator’ is not good enough, I must login as ‘root’ to install or update software.
I generally plan to try a few linux distributions, to get their feel.
I spent much of today downloading and installing Suse Leap, which was over 12GB.
That behaved similarly, but at least it told me what it wanted.
I now have to hit my collection of Unix books, and whatever else, to discover what the default password for ‘root’ is.
Once again, thanks leetaur.

Just for completeness here, I found that the root password is often the same as that of the first user created. It worked on Suse Leap. I have yet to try it on PureOs, but I’m encouraged.

Your ordinary user should have sudo rights.

If so, in a terminal you can do
sudo su -
you wil then be prompted for your prdinary user password, after entering that you are logged in as root
then you can set a root passwrd using the passwd command.

Thank you j_s, for your suggestion, which I will try.
I have just tried what had worked on Suse Leap, but on PureOs the root password is not the same as the first user created.
Ok, I just tried sudo su -
gave my password, and got to the bash-Konsole prompt of root@mycomputer:~#
Then opened the Discover application, and clicked on the GIMP install button.
“You have no authorization to execute this operation”
From this I deduce that my root authority only exists within the Konsole terminal, which makes the Discover application impossible to use.
Suse Leap has worked.
PureOs is being awkward.
I am wondering how much of my life shoud I waste fighting PureOs?

As I wrote, in bash-Konsole you can set any password for root using the passwd command (note spelling passwd).

Sorry j_s, I missed that, in all the excitement.
I’ll give it a go.
Thank you for persevering.
I did a fair bit in linux, some years ago, but am not now a frequent user.

Yep, still here.
I just got round to trying your WHOLE suggestion j_s.
sudo su - went fine.
after entering my user password, I am root@…
Then I entered passwd root
Prompted for new password twice.
Then says password updated successfully.
Then I get back out of the terminal and log out as me.
Then try logging in as root, with the correct new root password. …Login Failed
I tried resetting the PC, and then logging in as root. …Login Failed
I am not getting anywhere.
Does anybody know what secret password PureOs gives to the root?

root account may be disabled by default (regardless of what password it has). e.g. Expired root account

There should be no need ever to use the root account.

Interesting irvinewade.
But there is a reason to use the root account.
It seems only the root has the authority to install or update software applications.

That must be something unique in your situation.

I’m using mostly Ubuntu on desktops/laptops, Raspbian on Raspberry Pi devices, and PureOS on the phone … and, like all(?) Debian family distros, you have to become root in order to install software (and do many things besides), through the use of the sudo command, but you never have to log in as root, root doesn’t even have to be valid or possible to log in to, and the password that you give to sudo is your own password, not the non-existent password of root.

As with any computer system, if some access is not needed then that access should not even be possible. So good security practice is to leave the root account disabled and impossible to log in to.

So my recommendation would be to get to the bottom of the underlying problem.

I would suggest using sudo apt ... at the shell prompt to install and update software. Worst case, you may at least get an error message to work with that may get to the bottom of the underlying problem.

Thank you irvinewade.
I will explore your suggestion.
I have a couple of unix books. Unix - The Book, and The Unix Software User’s Handbook.
I think the design of pureOs may be the root of the problem.

I’m having the same issue. It’s my second day with an instal of Pure OS on an older Lenovo Thinkpad. I get:
“You have no authorization to execute this operation”
when I tried to do the initial updates through Discover. I updated through:

sudo apt update
sudo apt upgrade

That worked.
Then I tried to install Calibre through discover. Again, only:
“You have no authorization to execute this operation”

Could this be because I am using Pure OS on an old Lenovo thinkpad and not a pure device?
When I go to the settings in Discover, all I see is that three Byzantium repos are enabled, and I enabled anonymous user information.

I would be grateful for any help/suggestions to get authorization. Any potential solutions?

You should be able to install it by using: sudo apt install [software package name]

1 Like

You’re right. Thanks. Gajim is installing that way. This is going to make me better at the command line until it gets fixed.

1 Like

I made a bug report through Discover. I got thsi reply:
Resolution|— |DOWNSTREAM

— Comment #1 from Bug Janitor Service <bug-janitor@kde.org> —

Thank you for the bug report!
However Plasma 5.20.5 is no longer eligible for support or maintenance from
KDE; supported versions are 5.27, and 5.27 or newer. Please upgrade to a
supported version as soon as your distribution makes it available to you.
Plasma is a fast-moving project, and bugs in one version are often fixed in the
next one.

If you need support for Plasma 5.20.5, please contact your distribution, who
bears the responsibility of providing support for older releases that are no
longer supported by KDE.

If you can reproduce the issue after upgrading to a supported version, feel
free to re-open this bug report."

1 Like

This looks like a bug on the side of Purism ⚓ T1117 [KDE Plasma] Discover "Failed to obtain authentication"

1 Like