[13v2] Webcam killswitch does nothing

Recently, I’ve noticed that the camera+microphone killswitch on my Librem 13v2 does nothing at all. Meaning, even when it’s switched off, the OS can detect and use the webcam and mic without issue, as if the killswitch simply didn’t exist. I’ve tested this in both PureOS and Qubes (the OS shouldn’t matter, as it’s a hardware switch, but better safe than sorry). The adjacent killswitch for WiFi and Bluetooth works just fine. I’m fairly sure the switch worked when I first received the laptop, but I use my webcam and microphone very rarely, so I have no idea when exactly it stopped working.

Is there anything I could do on my part to diagnose the issue, or possibly even to fix it? It’s not a huge problem for me, as I mainly use Qubes, which isolates the webcam and mic from most software, but that’s still not as reliable as a hardware solution.

Yes, there are many adhesive solutions to this problem. Even if just a band-aide for now. But id say you may just have a broken switch tho no biggie.

Thanks, but I know bandaids exist. I’m more interested in finding a way to fix the switch.

1 Like

My apologies. I didn’t mean to be a jerk about that. I don’t know if you’re still under any warranty but if you’re electronically inclined it won’t hurt to open her up and have a look. It’s likely something pretty simple to fix even a little dust bunny that’s not allowing switch to open. Or cracked solder point etc.