15v3 Anyone get Arch working? How did you get the firmware?


#1

I’ve done full arch installations on Mint using a vm with no problem, but the disabled bluetooth in BIOS is giving me major headaches. I found an earlier thread which gave the location of the debian package for “firmware-atheros” which would provide the necessary ath9k firmware. Here’s where I’m lost, though. How do I download this deb package for Arch, and also make it available to use during a fresh install?


#2

I don’t think Bluetooth is disabled in any sort of BIOS on the Librems. PureOS uses a Linux kernel free of blobs, which is why Bluetooth doesn’t work out of the box on PureOS.

However, based on this page, it seems like it should work with Arch Linux:
https://wiki.archlinux.org/index.php/Laptop/Other#Purism

However, you may need to install bluez.

https://wiki.archlinux.org/index.php/Bluetooth

I don’t know much about Arch and haven’t tried it on a Librem laptop, though.


#3

Thanks for the reply – I used “apt-get install bluez” in Mint. I tried “enable” which returned a confirmation message but still cannot discover to pair so I’m probably in over my head. I appreciate your help!


#4

Sorry, I think I am confused. Are you trying to get things working on Mint or on Arch?


#5

I mean Arch works, Parabola works, Hyperbola works… Bluetooth is proprietary I think. I don’t use it though.


#6

I can’t install it on Arch because “pacman -Sy bluez” returns “can’t resolve host” for a bunch of mirrors. Which would make sense, right, because there’s no enabled wifi to grab the package from if it’s not a pre-loaded package? I was thinking maybe there was a workaround where I could install the necessary firmware or packages somewhere that I could use during installation. Again, I’m probably in over my head. Just annoying since I got everything else to work. Thanks again!


#7

Bluez
https://www.archlinux.org/packages/extra/x86_64/bluez/download/

Any other package that you need
https://www.archlinux.org/packages

Copy them in a memory stick and install them with pacman or whatever, I don’t know Arch commands.


#8

I installed arch without any special drivers I used “wifi-menu”


#9

Wifi should work - the chip’s Wifi works with libre drivers, just not the Bluetooth. I know Arch keeps things pretty minimal, though, so yeah, I think it’s a matter of getting the right package and loading onto a USB as described by others.

Or if you have a USB-to-Ethernet adapter handy and can use a wired connection, then you can install the wireless packages with that.


#10

That was one of the first things I tried, but no networks were listed.


#11

Have to ask the obvious question, just to ensure it isn’t the case: is the hardware killswitch set to allow Wifi/Bluetooh? Obviously, if the killswitch has cut power to the card, you won’t see networks.


#12

Yes haha, I triple-checked that before anything else. And they worked with Mint, so that definitely isn’t it


#13

I have been running Manjaro for years on a 13v3. Might try that. Based on Arch. Might want to try it.


#14

parabola usb worked for me try that.