20220322 Update problems

Hi all,
yesterday I turned on my L5 to see if there were updates.
And yes there are.
When I started the download I got an error ‘unmet dependencies’.
How can I try to solve it?

1 Like

Go to shell prompt and do
sudo apt upgrade
so that you can see what package has a problem and what the unmet dependencies are.

I am assuming that you are using only the Purism repo and haven’t installed any .deb files manually.

Is this amber or byzantium?


Yes I’m using only Purism repo, byzantium.
After the upgrade it seems solved.
Do you suggest me to install others manually? Consider that I’m a simple user… more simple is better is for me :sweat_smile:

1 Like

I do not trust this app PureOS Store. Sometimes it crashes even on startup. At the moment it says “all is uptodate, last checked two month ago”, but it updated Gnome and Telegram yesterday.

I mostly use sudo apt update && sudo apt upgrade


Thanks for your tip. Not nice to read that app PureOS Store is not ‘relaible’ in particular for a simple user like me :sweat_smile:

1 Like

I see it as an advantage that it does not work realible…

Because it’s not really Purism’s “fault”. It’s because upstream Gnome software just has never worked well for me and for anyone I personally know. The more people have a Librem 5 the higher is the probability that this software gets fixed someday. :slight_smile:


It’s possible that Purism were making changes to the repo and @MV71 just happened to try an update at a bad time. I don’t know whether repo changes are atomic. ???

Please use sudo apt full-upgrade instead, upgrade isn’t going to replace obsolete packages which may in turn hold some updates up.

Yes, exactly. The purpose of the command was to get a more complete error message, not to make the upgrade go ahead. :wink:

Probably off topic but what is the message that flashes on L5 screen after the encryption passphrase is entered when turning on? It happens so fast couldn’t capture it.

cryptsetup notifying that it unlocked the filesystem successfully. I plan to take a look at getting rid of it soon.

1 Like

Ideally the unmet dependency log would simply be stored and accessible within the pureos store software app. It just has to reveal and store installation logs from each attempt, it could be a running degister log.

Thanks for that info and help. It is a cool phone!

hi all,
an other update problem.
Some days ago I tried to update the phone, as I do regularly hoping of a solution for the battery management.
The L5 shows this.
Could anyone let me know what does mean please?

Is something wrong with your phone’s time and date?

1 Like

no, date and time correct. I’m really sick of this phone. even the basic functions are not stable after years

That happens to me too. I just refresh the update button and it updates okay then.

I have i librem 5 too and i never using for daily driver because it not ready yet, i will NEVER use the Librem 5 with an extra battery just for use it, this a crazy thing.
The good news is that L5 has everything to be a decent truly gnu+lnx phone, probably will be at PURISM GNU OCTARINE.
It very different with the opensource pinephone-pro which i don’t see any future as a phone for daily use, ppp it will simply never be like the librem 5, i suggest to buy the sparklan-wlan-controller.

I don’t really trust the pureos store app either, you should just be using the command line until it gets more reliable.

1 Like

So the app is not reliable but has worked for me this whole time with caveats:

  1. gives errors or issues or forever loads
  2. x out the error and close the app
  3. in gnome usage kill the app process if it runs, remove the cache
  4. relaunch software store app and update, it typically works again