4G LTE modem problem and fix

I had been using my Librem5 for about 2+ months with no real issues with 4G cellular service. At times it would drop the connection but usually it would connect quickly by itself. Rarely I would have to reboot.

But yesterday after getting some texts and fetching some data, it suddenly wouldn’t make any connection to either calls or data. It did show a cellular signal but the network showed there was no connection. I tried changing the APNs, restarting the modem both with the switch and software. I went to my cellular service login and made sure everything looked OK there. I tried shutting down and taking out the SIM and rebooting.

No matter what I did it was dead. So now it’s either a service provider issue or a Librem hardware/software issue.

The last thing I knew I could do to hopefully make it work was to try resetting the modem. I went through the steps of changing back to the 3G defaults. After I saw I made that change and got the error when trying to to connect to cellular I went ahead and redid the steps to enable the 4GLTE settings on the modem. Luckily that worked.

I realize that I’m fortunate to have the capability of an opensource smart phone but that really sucked. From one moment to the next the 4GLTE either reset or corrupted for no apparent reason. Meaning I was cut-off for about half a day and it was about 2 hours of dicking around trying to figure out if and when I’d have my cell service back. Data was no big deal I could always go wifi or even plug in an RJ45 thru a hub.

Bottom line - unfortunately your cell connection could instantly vanish and going thru the steps of manully resetting the 4GLTE modem may be the only fix.


I’m not sure what happened but I’ve got Good News! Because you have an opensource device it is possible to create solutions. If this sequence (what ever it may be) is needed to be repeated, a script to automatically do that is possible - even a timed interval script - until the problem is found and fixed (which needs a bit more information on the problem for troubleshooting).

edit to add: In addition to contacting purism support to create a ticket with relevant detailed info, the sequence you needed to re-enable 4G could be interesting to know - and possibly that could be made into a script here.

1 Like

With my Librem5 the situation since the last kernel update became a lot better.

Anyway, I adopted some scripts from the issue about the problem to monitor and reset the modem when it vanishes. Unsorted information about that can be found here: https://source.puri.sm/-/snippets/1188

udate: looked at my L5 and found that it lost and recovered its modem over night. first test of my setup successful…

1 Like

It looks like what I took for granted for 5 months of 3G cell service and then about 2 months of 4GLTE service has come to an end. Since this happened to me less than 3 days ago, I’ve had the cell connection drop chronically about 4 times.

The first time it was just plain down for nearly half a day with about 2 hours of that having me try different things to start it back up. That first time is what I outlined in the original post.

When it dropped the 2nd time(later that day) I did the reset again. But it didn’t just pop back to 4G service like the first time - but the 3rd and 4th time I was able to get it started up with a reboot and changing between different APNs. It usually reacts strange between what 3G or 4G network displays. Despite there shouldn’t even be a 3G signal. I’ll also get the network disconnect icon going on and off. Sometimes that new Gnome network orange indicator goes on and off too. When I test under these conditions there’s no calls functioning and usually if the data does work it’s very slow. During the next 10 or 15 minutes it seems to finally go to a solid 4G showing and everything then works. It’s as if it needed time to seek and find the 4G signal. The other nice thing to report as of now is the 4Gs been up for about 10 hours and counting… I need to find some wood.

Of course it’s been so unpredictable thus far that I don’t expect the above behavior to stay them same. I did see that the new 5.18 kernel came in last night and I’m running that now. Hopefully that will help.

Sent from Purism Librem5

1 Like

had to move it here https://source.puri.sm/-/snippets/1203