A few issues with Parabola


#1

I recently received my Librem 13 v3 and am quite happy with.
I tried out PureOS for a few minutes,
but then swapped the SSD with the one from my old laptop,
which has Parabola installed on it.
(So I am using the same installation as on my old laptop)

It works well, but there are some issues that not just annoy me,
but sometimes get in the way of my work.
I guess installing some package or configuring something will solve most of them,
but I could not find any (working) solutions myself.

Let’s start with the least important one:
Like all laptops, the Librem 13 emits and electronic whining sound,
when the backlight is not at 100%.
To my surprise, this whining sound is considerably louder in parabola
compared to PureOS and Ubuntu.
Same is also true for the typical electronic crackling noises expected in laptops.
In Parabola, they even get louder when touching the touchpad… :no_mouth:
I played around with all sorts of powersaving options (tlp, cpu governors and co) but could not solve it.

My second issue: When playing videos, sometimes graphical glitches appear on screen.
They look like grey static boxes, which cover the full width (even when the video is not in fullscreen) but rarely more than 50% of the heigth of the screen.
I found a few threads in this forum about problems with the CPU and its integrated graphics, but the suggested solutions (the kernel flag i915.enable_rc6=0 and i915.enable_psr=0) did not solve the problem for me.
I did not encounter anything similar whil testing PureOS, but that might be just because it is quite rare, but I had my screen crash two times this week (The screen just froze, even switching to a TTY did not help, but the operating system was still running fine),
which I think might have the same cause, since my X server was perfectly stable on my old laptop.

The most annoying issue is with the GRUB bootloader:
It randomly freezes when booting: Sometimes when loading the kernel, sometimes when loading the initial ramdisk and sometimes even [though this is extremely rare] directly after displaying the ‘welcome to GRUB’ message.
Usually when this happens, I have to retry about two to three times, before booting successfully.
I have only encountered this issue with Parabola, but maybe I have just not booted into PureOS often enought to encounter this.
I have absolutely no idea what may cause this; I’ve tried reinstalling GRUB a few times and I’ve looked at /boot/grub/grub.cfg in PureOS to find, if there was anything special in place, but found nothing.
The live version of Ubuntu I tested always booted perfectly, so I suspect syslinux is not affected, so if this can’t be resolved I might have to chang my bootloader…

My kernel version is 4.16.14-gnu-1 and my CoreBoot version is 4.7-Purism-4.

Any attempt at helping me is highly appreciated! :slightly_smiling_face:


Parabola GNU/Linux-Libre Wiki Entry
#2

I have similar issues with grub. However, as I need to type a quite long disk encryption passphrase, I rarely manage to get through (sometimes it fails for hours) and it is even more annoying. I’m running Qubes OS (the relevant part is Fedora based) and many people reported this issue on Debian based distros, so it is probably not OS specific.
Update: For me i915.enable_rc6=0 removed the freezes of grub (but there are still freezes when the system is running).


#3

It has been a long time since I was here, so I thought I might talk about how these problems were solved.

First of all, my device was RMA’d, meaning exchanged for a new one, which was definitely necessary, as the issues (except for the GRUB one) were mostlikely hardware caused and got considerably worse over time. The RMA in germany is handled via another company, which acted fast, so I did not have to wait a long time at all. In general my interactions with the Purism support have been quite positive: They respond fast and know what they are talking about.

So I got a new device some time ago and all issues except for the GRUB one were gone.

I tried using syslinux instead of GRUB but had the same issue. I suspect that that disk was badly formatted, so I got myself a new drive and freshly formatted and installed parabola onto it. This solved this issue as well (Although I am now using syslinux, it is mostlikely that GRUB would also function as expected on this new installation).