Adding additional repos and personal package archives (PPAs)

I have been trying to add a repo to my PureOS green installation,

sudo apt-add-repository ppa:teejee2008/ppa

but gpg complains that it cannot find a Public key,

gpg: keybox '/tmp/tmp87i6nc_k/pubring.gpg' created
gpg: /tmp/tmp87i6nc_k/trustdb.gpg: trustdb created
gpg: key B5B116B72D0F61F0: public key "Launchpad PPA for Tony George" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1
gpg: no valid OpenPGP data found.

If I try to sudo apt update anyway, I get a gpg error msg

GPG error: artful InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B5B116B72D0F61F0

The repo author has listed the public key on the launchpad wesbite. Can I manually add this repo?

The ppa is aimed for ubuntu OS, is there an equivalence between Ubuntu and PureOS releases given that they are both debian flavours of linux?

1 Like

Isn’t appropriated add Ubuntu PPAs in Debian it can give you dependencies problems, although it doesn’t always have to be problematic.

To add the GPG key:
sudo apt-key adv --keyserver --recv-keys B5B116B72D0F61F0

1 Like

Thanks @uzanto, unfortunately that doesn’t work for me,

Executing: /tmp/apt-key-gpghome.3eHN52QxFE/ --keyserver --recv-keys B5B116B72D0F61F0
gpg: keyserver receive failed: Server indicated a failure 

I ran the gpg in verbal/debug mode to see what the Server error might be,

> gpg -vvv --debug-all --keyserver --search-keys B5B116B72D0F61F0

gpg: reading options from '/home/vrata/.gnupg/gpg.conf'
gpg: using character set 'utf-8'
gpg: enabled debug flags: packet mpi crypto filter iobuf memory cache memstat trust hashing ipc clock lookup extprog
gpg: DBG: [not enabled in the source] start
gpg: DBG: chan_3 <- # Home: /home/vrata/.gnupg
gpg: DBG: chan_3 <- # Config: /home/vrata/.gnupg/dirmngr.conf
gpg: DBG: chan_3 <- OK Dirmngr 2.1.18 at your service
gpg: DBG: connection to the dirmngr established
gpg: DBG: chan_3 -> GETINFO version
gpg: DBG: chan_3 <- D 2.1.18
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> KEYSERVER --clear hkp://
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> KS_SEARCH -- B5B116B72D0F61F0
gpg: DBG: chan_3 <- ERR 219 Server indicated a failure <Unspecified source>
gpg: error searching keyserver: Server indicated a failure
gpg: keyserver search failed: Server indicated a failure
gpg: DBG: chan_3 -> BYE
gpg: DBG: [not enabled in the source] stop
gpg: random usage: poolsize=600 mixed=0 polls=0/0 added=0/0
              outmix=0 getlvl1=0/0 getlvl2=0/0
gpg: secmem usage: 0/65536 bytes in 0 blocks

but I am no better off.
I am trying to install timeshift in order to backup my machine before doing an upgrade.

However, is it possible I need to upgrade in order to get the above to work?

Work fine for me,
Executing: /tmp/apt-key-gpghome.vwHceuQVhn/ --keyserver --recv-keys B5B116B72D0F61F0
key B5B116B72D0F61F0:
1 signature not checked due to a missing key
gpg: key B5B116B72D0F61F0: public key “Launchpad PPA for Tony George” imported
gpg: Total number processed: 1
gpg: imported: 1

Can be a DNS error which ones are you using?

Try ping -c 1 if it doesn’t work try changing your DNS through resolv.conf

Anyway you can use DejaDup to backup your machine, it’s the default Gnome Desktop app to do that.

Ya, I checked the DNS, although gpg error code for DNS resolution error is different from the one I get. I usually set my DNS to ISP provider to reduce lag, but I also tried setting up to the google configuration but it didn’t work.

Sure, I am using it already for my home drive, however, DejaDup expects you to know what system files to backup, which means I would need to do a lot fo bg reading to figure out how to take incremental snapshots of the system files into order to get a decent backup to which I can roll back to in case an upgrade goes wrong.

Timeshift takes care of that for you. Ultimately I want to be able to do backups of my system files onto a dedicated encrypted USB flash drive.

Do you use DejaDup for system backup? Which files are you backing up?

I am thinking my error could be due to an outdated file/library. I am going to upgrade in the next few days and report back here if I solve this issue.

I am still unable to get get the public key using the command,

sudo apt-key adv --keyserver --recv-keys B5B116B72D0F61F0

googling the error I get, reveals a likely issue with the dirmngr DNS resolver, I still can’t understand why this is happening. I tried enabling the --standard-resolver in ~/,gnupg/dirmngr.conf but that didn’t make any difference.

However, I managed to import it manually using the following instructions, and the key from this page.

I am now able to update timeshift from the official repo.

Old topic, but I have the same problem, with the same software developer. Instead of timeshift, I’m trying to install the aptik software. But it uses the same repo and key. My question is regarding the last post. The instructions linked above have the following steps:

Try this, assuming you’re using Ubuntu:
1 In your web browser, go to
2 Copy the pgp public key block, including the lines saying “begin pgp public key block” and “end pgp public key block”
3 Paste it into a text file and save it anywhere.
4 Open System->Administration->Software Sources, put in your password if asked, and click on the Authentication tab
5 Press the Import Key File button, select the file you just saved, and press OK

How do I do the equivalent of step 4 in PureOS?


Okay, did a bunch of reading and decided against this method. Also, turns out the author of the package has a .deb linked in this page:

this needs to be kept bumped.

1 Like