Again, Cannot Get Past Boot Generic Error

  1. L5 was shut down normally i.e. Notifications - Power Power off, yes power off @ about 3:30 A.M. today.

  2. Still today, I powered up the L5 got:

crypt_root: setupsuccesfully

That’s normal but what happens next isn’t:

Blockquote I-cancel-msg:Press Ctrl+C to cancel all filesyste

Yes, it ends exactly like that.➹

QUESTION. Just how is one to use CTRL+C because there are NO “Ctrl-C”. No keyboard, no “C” and NO CTRL available. So that is not very helpful.
Flashing should not be the fix. Shouldn’t need a fix. Shouldn’t have gotten ill over a normal power off.

All I can/have been using it for is texting - period because STILL, taking a picture takes a long time to fiddle with the settings to get it right. So I gave up on it even being a camera too. I don’t play with settings, or code, or anything. Just Texting.


Side note: Please get this forum tool to use Blockquote working properly. We should not have to try deleting the Blockquote or List item pre-sets manually.

1 Like

I had the same issue last week. I could not boot the phone for an entire day.

The problem solved itself. Or at least I didn’t do anything different : just pressed the power button and this time booted up

1 Like

I’ve gotten that also. However with no intervention on my part it went to the screen lock password in less than a minute and everything was normal.

1 Like

Sometimes there needs to be a filesystem check. I’ve also experienced this message for the first time recently on my L5. I plugged in an external keyboard so that I could type Ctrl-C. That was after waiting about 10 minutes just in case…

1 Like

I imagine this is: Press Ctrl+C to cancel filesystem checks in progress.

This is part of the normal Linux boot process i.e. check the file system integrity every X boots / every Y days. You can configure X and Y, including suppressing the check entirely but …

It isn’t normally a problem. In fact it’s a good thing. You just let it finish.

Where it is a problem is if it never finishes. Is that what is happening?

Do you have a µSD card in the Librem 5?

Linux checks each file system according to the individual file system’s settings. So if you have two file systems (for example, the main file system on the internal eMMC drive and the file system on the µSD card), you can end up with the boot stopping to check a file system quite often (and in that case I choose to synchronise the checks so that they occur together or not at all).

In principle you could try connecting a real keyboard via USB - or docking.

1 Like

Just because that message shows, it does not necessary mean that this is the actual error that prevents booting.

My Librem 5 sometimes has problems booting (ever since I switched WiFi cards, so I blame myself) and it helps to just switch the WiFi/BT killswitch to off and it boots fine. After Phosh has started I can then turn on WiFi without problems.

Maybe trying this helps in your case, too.

1 Like

Woot woot!

I used your keyboard idea, and plugged Hoyoki (dock - same as sold here) .into L5.but it didn’t work until I unplugged the keyboard / mouse dongle from dock is when the screenloack opened on the L5.
It sounds like your dock recognizes a keyboard even before the screenlock password. My connection won’t. So:

  1. I unplugged everything on dock: L5 was on the pwr supply cable.
    2 tried keyboard first, no change.
    3 Tried monitor
    4 Removed plugged in dongle and got the screen lock. Replaced dongle.
    5 Enter pass for screenlock and made it in to desktop.
    6 Went to Settings > Displays (display opens in a micro-small text) on the L5 and monitor, but can only move the Displays settings page left & right with mouse because mouse can’t work on monitor till it’s set yup. I do this each boot.
    7 selected #2 screen from the example, then click my Samsung monitor, and hit “Apply”, wait about 15 seconds, and the screen appeared. It’s moid-sized micro-screen still, but I enlarge Displays screen and it jumps to the proper size. Now I’m ready :face_with_spiral_eyes:

Now I can, I hope, continue to get in. It’s enough to have to set up the Display every time…

I see @irvinewade explains what it is quite well in Msg 4/6 below.


I guess I missed that memo.

And we are supposed to know that? And, I did leave it for 30 - 45 minutes as I ploughed through manuals, documents and wiki’s looking for a solution, another 20 wasted minutes with Google. So it had time to finish.

When I pressed top-R side button (Pwr) quickly, it wouldn’t come back. It was a good 3.5 hours, that was day before yesterday, I tried again yesterday and unplugged L5 from Hoyoiki and back on straight to pwr supply.

My reply to @pajuky in Msg 6/7 the steps I took based on their ‘keyboad’ scenario.

By that, I meant the L5 keyboard. Understand that at night, I shut down the L5, remove the dock from L5 and remove pwer from dock, and plug pwr into L5.
In a.m, repeat logins and re-set up external stuff attached to Hoyoki.
It’s why I went on a hunt for a decent dock. Finding none, I bought the Hoyoki.
I do the switching from Dock to pwer supply because of the unacceptable heat generated in both the L5 and Hoyoki dock.

Correct, but only if a hour or more counts as waiting for it to finish. I’ll have to wait until “never” to see if it starts. :smirk:

But if these ‘checks’ are on random days, then we’re left with a dilemma; disable the check, which is not a good idea, or wait when a unknown amount of time to see if it starts starts. If not, look through notes I’ve gathered to find the fix again.

Yes. 64 gig “Generic Ultra HS-SD/MMC (2.09)” It’s in, formatted and visible in “Disks” I’m not using it. It does have a file system though.

I will try to set the file system check to cease or set both file systems synced as you suggest & pick my own day and time, & when not docked.

A ton of thanks Irvine.

I’m sure that the user experience could be improved here, particularly if the message is being truncated.

  • Needs an explicit message at the end of the file system check (to say that it is done).
  • Ideally would have a progress indicator.

As to whether you are supposed to be familiar with that message … it must surely come up from time to time on your Linux desktop / laptop? But, yes, if you were a first time Linux user having bought the Librem 5, it would be unclear what that message is all about.

As I said, file system checking at boot is a good thing. You can examine the current settings with
sudo tune2fs -l /dev/xxx | grep -E 'Mount count:|Maximum mount count:|Last checked:|Check interval:'

where xxx is replaced with the appropriate device name for the specific partition that you want to check (usually the partition of the root file system).

1 Like