AirPods Pro 2 Worked... then stopped

Got the new AirPods Pro 2… paired them up and worked fine up until now. Now when I pair them… no audio… yet shows the device is connected and the audio output for the AirPods is selected. Any idea whats going on?

1 Like

Is the volume down?


volume is maxed… and no sound.

1 Like

The problem was fixed temporarily with a USB BlueTooth adapter. Now it’s broken on either device.

1 Like


1 Like

Hi, not sure if its like this on the Librem5… just check it out:

I think your Blutooth System remember the ID of devices and when its broken it have issues to reconnect. So i hope that you have a tool like:

$ bluetoothctl devices

bluetoothctl described on that link. And you see all devices in range with:

And List of already paired devices:

$ bluetoothctl paired-devices

Or remove a device with the id/Address (FC:69:47:7C:9D:A3) with:

$ bluetoothctl remove FC:69:47:7C:9D:A3

The first steps on that Page describe how to check with systemd if the Bluetooth Service is running and up. Check this out too. Hope it helps.

I think you can identify it and unpair it, o mark it as a “trust” Device or put other on the block List and so on. Ah you enter that commands with a Terminal. However its more comfortable with a lager screen and Mouse/Keyboard.

Edit: Sorry i think just about the Phone every time, on other PureOS Systems and the Laptop you find some more Information in the Bluetooth Settings? Sorry i like that Terminal commands, cause it often is the same on many Linux Devices. And you get more specific Error messages.

You can take a look in dmesg too:

$ dmesg

You find more messages from different parts of your System, however the recent ones are at the End of the output. So if it work… and got unworking again, check out the End of dmesg,

1 Like

Still not able to pair AirPods Pro 2 :confused:

1 Like

I found this post with a supposed solution to the airpods, audio - Bluetooth Issues with Airpods Pro 2 on Debian 12 - Unix & Linux Stack Exchange

After installing the package libfdk-aac-dev and extracted and places the codec in the location listed, rebooted, but it still does not work.

Any thoughts? Does L5 PureOS use pipewire or pulseaudio?

1 Like

I did a little more digging, and it seems like PureOS uses pulseaudio for bluetooth.

I found a github which has codecs for aac, but I am unsure if it is a simple “place the file in this location” type of thing.

There is an option to build and replace current pulseaudio, but I am unsure of how to restore the backup if it goes sideways.

I don’t have as much time now to create a backup of the data on my L5 and try it out, but I thought I would update on progress so far for anyone else who may need it.

1 Like

Gnu crimson will enable what you want it.
It is same issue for Sony LDAC and Apple AAC: however on my test on this codec it worked untruly for some reason on Gnu system, however it may work more truly on a Linux Opensource Propietary system.

I did a test on Android/Linux devices about LDAC and AAC, and i see that it could be truly or untruly depending on audio source, however on most time it is fake hd audio resampled.
So in resumen this feature it very complex because it needed many dedicated part to work together.

Sony enabled ldac from android/linux jellybeans and wpan 3.0 controller, now sony support ldac under LE Audio wpan but same Master and Slave compat needed for.

1 Like

If I understand you correctly, Crimson has those codecs installed?

If so that will be a nice feature to look forward to. I have over the ear bluetooth headphones from JBL that work fine. I just thought I would see if I can get some airpods I got for free to work for when I want to carry something more compact.

1 Like

Yes Gnu Crimson comes with newer package versions installed like Pulseaudio, Gstreamer, Bluez that enablement AAC etc codec over WPAN, but also Gnu Crimson brings more tons of WPAN fixes and features.