Anbox installation

Hello Librem 5 community,

I’d like to install anbox to get Signal.

seems to be the right place to start.

Following this installation guide I got this issue:

 $ sudo add-apt-repository ppa:morphis/anbox-support 

run fine

$ sudo apt update E: The repository hirsute release does not have a Release file.

After some search, I found this on the wiki’s FAQ

which does not describe the same way for install it.

So What is the correct way to do it?

And could you help me with this?

Thanks a lot


Checkout this reddit thread:

I don’t have an L5 but that should work. Just fetch files from source and then setup. Also, I would highly suggest to use molly-FOSS which is signal with the signal network and everything but without the scary google crap. It still has a giffy thing which is owned by FB but it is better.

@Tengu, the instructions to install Anbox as a Snap are from March 2020 and written by a person who is not a Purism developer, which is why I put the more recent instructions from @dos in the community Wiki.

thanks! could you post the link to the instructions please?

so people here managed to run signal via anbox on L5?

1 Like

what is your point?

OK, so I’ve been trying to install anbox following the WIKI FAQ:

before installing the 2 .deb from, dependencies (lxc and more) must be installed.

Now I’m stuck with docker service which does not want to start.
This is related to kernel module not founded (aufs)

modprobe: FATAL: Module aufs not found in directory /lib/modules/5.11.0-1-librem5


@dos I would suggest to update the link, so that people don’t get confused

Doesn’t my link explain how to install Anbox? I didn’t try this myself, so cannot comment.

unfortunalty not
thanks anyway

1 Like

This is a Debian packaging repo; that README comes from the upstream project, is unrelated to the Librem 5 and can’t really be cleanly changed without forking.

Thanks for you answer.
Looking at the URL one cannot say that this is NOT related to Librem5, isn’t? :slight_smile:

Could you please point out a way to install anbox that is fully working with the current Librem5 kernel?

with gratitude


I was able to install anbox and run a few apps using the steps outlined by Sebastian on Reddit, he’s a L5 dev so it’s legit.

I think the CI only builds Amber, so it might not work if you updated to Byzantium.
Download the zip from here and install the debs:

Then follow the steps here on a laptop or desktop with 60GB of free space to build the android.img:

Then when you put that file in the right place like it says, you can run anbox and then use adb to install apks.


The instructions in the Wiki fail. Looks like the PPA is not set correctly:

E: The repository ' impish Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Any way to get around this error?

DISCLAIMER: I am not Librem 5 develper

I have tried to help somebody else demanding andbox in the other thread when I have seen that he tries to run x86 Docker images to build android system image on the phone.

You do not need to build actual andbox binary, it is provided by CI build at Purims gitlab. Look for latest pipeline package-pureos-byzantium:arm64 artifact, download it expand and you have the required deb. But you need Andoid system image.

At the end I have managed to build image from android sources by scripts provided in the Purism project fork . But actual andbox is easy to build. Problem is matching Android image. I have managed to build it after some hacks to the build process which has to be run on host GNU/Linux x86. May system has too little memory that I have problems but next changes helped me.

Resulting image works in the respect that it is able to run all ART and Dalvik machinery and run included calculator and even F-Droid and probably even install some application. But at least my built is far from state that it can be reliably used and it is based on old Android runtime. May it Wandroid can be in the better shape one day.

It would be great if @dos can report his level of the success, may it be it is breakage of my build. It would help to inform others why build Android root filesystem image is not provided. Is it licensing, problem to keep too much data to fulfill source availability or what are other reason why Android image is not made available? Its build takes really long at least on my not so dated but standard hardware.

1 Like

And instructions at wiki should be updated that inform people Android image build is intended for host PC. Because unlucky ones can try tat on the phone…

@YouTecho, Welcome to the forum.

I had tried Anbox on Librem 5. It is riddled with too many issues. (does not work as expected, hangs, screen freezes etc.) . Comes out, Waydroid is a better solution. You may want to try as per @dos’s instructions

Please update how did it work out for you.

1 Like

The necessary kernel modules aren’t available.

Now that kernel 6 is available (via apt-get update) @dos, does it have all the required kernel modules for Waydroid to work?

To be clear, I was talking about anbox.