AWEsim, AT&T - can't place call or receive

Hi Everyone,

I was looking for some feedback on a problem I’m having with my L5 using AWEsim on AT&T. I’m not sure if its a reception issue, but I’m currently at 60% signal strength and unable to place a call. It won’t even try, the call just goes nowhere and is logged in my recent calls as a fail. One more thing, does it matter under the modem status that the network status is unregistered?

Any advice, before I contact support?


Very likely yes!

For starters, I would use the kill switch to kill the cellular modem, leave it off for 20 seconds or so, then switch it back on. Then give it enough time to acquire the tower.

In Settings / Mobile, you would probably want to check Network Mode (I have “2G, 3G, 4G (Preferred)”.) and underneath that check that Network shows something (I have my carrier’s name.)

Within Modem Details, I see Carrier (same again), Network Type (“lte”), Signal Strength (“73%”) and Network Status (“Registered”).

An obvious question would be: has it ever worked? i.e. was working before but not now? - or never worked? If it has never worked, I would check the positioning of the SIM in the tray and/or fault isolate the SIM in another phone (if that is an option for you).

It’s hard to say whether 60% is enough because for a start I don’t know how it is converting the real value into a percentage. The real value (RSSI in dBm) can be obtained with an AT command but let’s see whether we can avoid going there.


Hi Irvinewade,

Thanks for your response! I’ve tried to set it to the same mode as you, however signal strength drops to 10% and 0%! With the low a signal strength I cannot place/receive calls. Funny, my Puretalk sim uses AT&T and it works with the 4g. That’s why I tried setting it to 4g only, get better signal strength, but it won’t register with the network - d’oh.

This has never worked for me period. I have sent an email to Purism this morning, and started the process of getting support. I’ll note the findings here.

I do appreciate the reply my friend! Have a great day :wink:

1 Like

The Librem 5 needs a 3G (or 2G, which no longer exists on AT&T) connection for calling, due to the modem’s current lack of VoLTE-capability. Setting it to 4G only will automatically ensure that no calls can be made. (Until and unless the VoLTE issue gets sorted out.)

(Note that some countries/carriers may not be requiring VoLTE yet, but the U.S. carriers do, or will soon.)

1 Like

Thanks for bringing that up Amarok.

I’m now fully versed on the VoLTE issue, what a bummer. Guess we will wait and see what Purism can do about this issue.

I’ve also requested to try T-mobile as a carrier, but been told Purism is out of stock on those SIM cards. Hopefully I can get some sort of signal, otherwise its not worth the $100 monthly for cell service via Purism. I love the idea of anonymity though!

Last choice is I can always go VOIP here at home via my existing PBX…

Thanks again, and have a good one!

1 Like

Maybe also VoIP using the LTE (4G) data connection of the phone when not at home. However that will only work if your VoIP provider allows that and your mobile provider allows that and the planets come into alignment.

I think VoIP dialling is coming soon.

1 Like

VOIP/SIP shouldn’t be a problem. You can even get a separate account for mobile, if desired. Some VOIP providers have SMS-capability, too.

I’ve been thinking a lot about the data-only SIM option, in combination with a SIP account.

In the U.S., the carriers typically will only issue a data-only SIM for tablets and computers, not phones. It will be interesting to see how they treat the L5’s modem: Do they think it’s a phone? A computer? A car?

If the local carrier won’t provide a data-only SIM, another option, as discussed elsewhere in the forums, is to use an international travel SIM, either a data-only SIM, or a regular SIM (and just forgo use of the included foreign number). The travel SIM gets the benefit of roaming on foreign networks, but without being subject to any device restrictions (presumably).

The trick is to find a travel SIM with cheap or reasonable data costs. I’ve seen a couple of those (and currently have one), but the cost-effectiveness is going to depend on how much data is needed per month. (I myself typically use less than 200 Mb! Lol!)

If they detect a discrete modem, I think they are much more likely to think it’s a computer or a car than a phone.

But is this condition enforced by carriers? I mean if you tell 'em it’s for a dongle for your laptop, would they know otherwise?

I have a data-only SIM that I use in my router (dual WAN) for a backup internet connection. (The SIM has SMS capability so, yes, my router can text me. LOL.)

Yes, they can tell what kind of device their SIM is being used in, probably by the device’s IMEI. Anecdotally, I’ve seen internet comments over the years from people who tried to switch their tablet SIM to a phone and were soon shot down by the carrier.


I think the IMEI is safe in the Librem 5. No carrier would ever believe that you have a discrete modem in a phone. :wink:

1 Like

Hehe, this makes it sound like a feature.


Do you still have the AweSIM service, and if so, is voice calling working for you now?

Hi Johnk,

Unfortunately not. I just could not get a strong enough reception for it, so I canceled. I loved the idea however, of a privacy minded cell service provider! Perhaps you will have better luck? Let us know your findings if you choose to proceed…



Same issue here, all options fail other than 3G only. 4G works but only for data not voice. So you have to sortof switch them everytime depending on usage.

My final solution was to cancel the AWEsim service and go with PuretalkUSA. Phone works like a champ :wink:

1 Like

i wonder then if its a simple APN configuration issue, not a hardware/modem/driver limitation. Thanks for the feedback! Data on Awesim works and is fast for me, too bad calls dont work yet over 4G.

Depends on how adventurous you are. VoLTE support progress

We recently pushed an updated mobile-broadband-providers package to PureOS that is “AweSIM-aware” and will list the proper APN to use when the SIM is inserted. As far as 4G calls, they work, however if you are adding AweSIM after the fact to your Librem 5, you will need to enable VoLTE. When we ship L5 orders that include AweSIM we set this up now, but we don’t set up VoLTE by default because depending on the provider a customer chooses, it is more likely to result in a phone that can’t make phone calls, than leaving it off.


Is there a tutorial on how to enable this on the Librem 5?

Edit: I think I found the issue with your write-up here. The link to the forum with the actual commands can be found on that issue page.

1 Like

FWIW I am using MintMobile prepaid sim that gives me: local number with 3G/4G/5G/LTE voice and SMS, plus 4G/5G data and voicemail all for about $18 per month.

Bought the card at Walgreens, activated it on my desktop, inserted in sim tray and it is working great.