Battery drain while suspended


#21

So, after installing the missing firmware and fully charging my Librem 15v2, it went from 100 down to 75% in 18 hours (suspended for the whole time). So a fully charged laptop would drain its battery while suspended in 3 days. For my usage, this is not a huge problem, but we are far from what is achieved by other laptops…


#22

I had this issue on a Librem13 v3 runining Manjaro and powertop seems to have stopped the bleeding. Basically I ran “powertop --html” and it generates an HTML report. There is a “Tuning” tab with a list of commands you can put into a script and run on boot and essentially change settings that waste power. This has stopped my lose of power when suspended. This page is Manjaro specific but I believe it will work on most distros.

https://wiki.manjaro.org/index.php/PowerTOP_to_Optimise_Laptop_Power_Consumption

Hope it helps.


#23

I tried the Powertop thing on my 15v3 and maybe it helped some, but it doesn’t seem to have fixed the underlying issue.


#24

Have you done a “sudo apt-get full-upgrade” ? I went back to PureOS to get the most out of the machine and saw (somewhere) to run the “full-upgrade” which I was not familiar with. It installed some more packages and my machine has been running well and the battery has been lasting well. Not sure if the full-upgrade is related but thought I would mention it.


#25

Thanks for the suggestion @Russ. I’ve done that just to be sure.

After a full-upgrade and a couple reboots, I closed the computer (which should’ve caused it to sleep), and left it over night for ~8h. Battery went from 96% to 56%.

I took the back cover off to investigate what was burning so much energy. It’s the RAM chips. They’re warm to the touch.
RAM is Crucial 16GB 260-Pin DDR4 SO-DIMM DDR4 2133 (PC4 17000) Laptop Memory Model CT16G4SFD8213

I’d very much appreciate any thoughts on next steps to diagnose this problem!


#26

This: https://www.reddit.com/r/thinkpad/comments/75ke0w/excessive_power_consumptionbattery_draining_while/
And the related: https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T470-Crucial-DDR4-memory-stick-gets-hot-while-suspended/td-p/3849858/page/2

Suggest it might be something to do with the RAM module itself. I’m going to get a different 16GB SODIMM to see if that changes things.


#27

I was going to say the same thing. Did you put this in? Do you have the 4GB chip it came with? Could try to swap and see if the problem persists.


#28

No, I don’t have the 4GB any more.

I’ve ordered a new 16GB; the OP in those two threads I linked to seems to have had success with a refund from Crucial–I’ll pursue that path.


#29

Sorry to hear it. I hate when you get a new toy and something goes wrong.
Good luck. The support guys at Purism are awesome. I would ask them for a recommendation for RAM. I went with their RAM since it was about the price of similar chips.
Good Luck.


#30

Similar issue here, to add another data point; I’m using a Librem 13v2 with the stock 16GB RAM stick, running PureOS, and the battery completely drained while suspended overnight (~8 hours) from a starting ~%60 charge.


#31

I also have 16GB and have the issue. Does anyone with less RAM check the issue?


#32

It would be great if you could share the script you are using.

In my case (Librem 13v2 with Ubuntu 18.04) the tuning hints of powertop did not help but being able to compare the scripts would be very helpful.

THX :slight_smile:


#33

Which RAM do you have?

sudo dmidecode -t memory

I have 16 GB,
Part Number CT16G4SFD8213.C16F (= Crucial?)
Manufacturer: Unknown (0)
Minimum/Maximum voltage: Unknown


#34

I’ve got:
Part Number: 16ATF2G64HZ-2G3B1

Similar to you, manufacturer, min/max voltage, etc., unknown.


#35

Sorry but I have moved back to PureOS and did not save the script.
Running powertool on PureOS gives me a similar list of things to update. I installed it an ran it.

sudo pwoertop --html

On the Tuning tab of the html page it generates there is a list of commands you can copy from the “Script” (comands) section of the html page it generated, under the “Software Settings in Need of Tuning” header… If you simply create a text file, add “#!bin/bash” at top, then the commands it should make the changes.
Once you have the script saved make it executable chmod +x (you script name)

run your script.

Once that is done rerun powertop

sudo pwoertop --html

You should not see any of the Tuning Updates Needed.
If this helps you will need to make your script a start up script or run it manually.

I have the same ram chip you have and I am not seeing this hibernate issue. I also did not use the powertool to update any settings.

Are you fully updated?

sudo apt-get full-upgrade

Good luck


#36

Woops, I have the same ram as veggies.
Part Number: 16ATF2G64HZ-2G3B1


#37

On my Librem 15v2, the RAM is DDR3L from Crucial, with the following specs and part number (2 sticks, so I have 16G):
8GB DDR3L, 1600 Sodimm, 1.35V
CT102464BF 160B.M16FP

Mathias
PS: If this is indeed the RAM sticks that are at fault, should we try to get a return from Crucial or should it go through Purism (or should Purism inform Crucial of this issue first)? (the online return form from Crucial is very simple, But I don’t want to ship my ram, hear that I can not return it directly and spend a few weeks without a working laptop for nothing)


#38

I used Crucial’s excellent cross-shipping process (so you don’t have any down time, you pay them for the RAM–> they ship you the ram --> you swap old/new RAM --> you ship them the old ram -->they receive the old RAM and you get a refund). I used their online chat to complain, and pointed them to evidence of the problem elsewhere online.

My new RAM is CT16G4SFD824A C16FE
My old RAM was CT16G4SFD8213 C16FH1

An overnight suspend of ~8h resulted in 86%–>79%, or ~7% battery charge loss, a marked improvement from the ~60% I was seeing. This is only one data point, we’ll see how it goes.


#39

I can confirm that with Samsung memory, the issue is fixed.

Part number M471A2K43CB1-CRC.


#40

@devnull can you say how much your battery is drained within one night (roughly 8 hours) to get a comparison to post of mpc?