Battery not charging after last updates

I updated my L5, I saw a kernel upgrade to 6.2 and other changes. But after a reboot, the batery seems to not be charging anymore with the phone on.
If I turn off the phone I see the red charging led on. Turning on the phone still with power cord, I see 0% always and no sign of charging, and no led indication of charging.

I try running the app powersupply from terminal, as with the gui it shows errors on all lines and got this:
$ powersupply Supplies found: Exception in thread Thread-1: Traceback (most recent call last): File "/usr/lib/python3.9/", line 954, in _bootstrap_inner File "/usr/lib/python3/dist-packages/powersupply/", line 84, in run battery_present = os.path.join(supplies['bat'][0], 'present') KeyError: 'bat'

It’s very strange it charges the phone when off(red led on), I turn it on the led goes off and the battery shows always 0% and after a while it turns off

Try the procedure listed here, L5 Phone Won't Charge and post the results.:blush:

Jut tried it, none of those procedures worked :cold_sweat:

What charger are you using. Because that happened me yesterday and then I removed the battery while it’s plugged in and put it back. And leave to charge for an hour. And then it worked

Original charger, I will try that

My original charger doesn’t work anymore I use a normal fast charger now

The original charger charges other phones here, just tried what you did, nada.

I manage to charge with a very improvised way, I need to first plug to a pc via usb c to usb a, then remove and insert the battery, charge untill fully charge. But then to start the phone unlug the cable, remove the battery, insert the battery. then the phone starts, but the battery lasts around 5minutes(it seems totaly uncalibrated). It was allworking fine before some upgrades, those that came with kernel 6.2. I am not sure what to do, I e-mail the support they answered me once, but not answering anymore. If someone has had similar issues, please help me.

One approach there would be to image your phone and restore it from an earlier image (or reflash it from an earlier image if you saved what you downloaded). That would attempt to discern whether it is the upgrades that are the problem.

Another approach is to use a multimeter to prove one way or another whether the battery has been charged.

1 Like

I reflashed pureOS, but got the latest version and have the same problems. How to reflash a previous versions?

I installed PMos to test it, and same thing. The phone does not charge when on with the cable plugged in. Also when on the batery shows always 0%, it looks like something reguarding u-boot. Any ideas of what can be the problem?