Battery not charging on not-yet-week-old Librem 15v3

My Librem 15v3 just arrived last Friday. It had been working fine until today. I have mostly left it plugged into the charger so far, but last night I used it unplugged for a few hours. I was impressed with the battery life, it was still at 34% when I set it back on my desk and plugged it in.

This morning, I flipped it open and everything seemed normal, except that I noticed it was still reporting the battery level at 34%. I assumed it just hadn’t charged overnight. I thought I would try unplugging the charger and plugging it back in to see if that would start it charging, but when I unplugged it the system lost power. It didn’t respond to the power button until I plugged the charger back in. When it booted back up it listed the battery at 0% and it still doesn’t seem to be charging.

501 ben@snow:~ 0 $ cat /sys/class/power_supply/BAT/uevent 

Interestingly, when I shut down the laptop, unplug the charger and reconnect it the battery indicator will initially be orange, but after a couple of minutes it turns white. I left it for about 15 minutes, then unplugged again and hit the power button but still no signs of power from the battery. Plugged it back in and it turned right on, but it reports the battery as empty and is apparently not trying to charge it. POWER_SUPPLY_CHARGE_FULL=0 seems suspicious to me.

I saw it recommended in another thread to check the battery connection so I unscrewed the back, and it looks like all the connectors are solid. A laptop without a working battery is useless to me, and ironically it was a failing battery in my previous laptop that prompted me to buy a new one.

Towards the bottom of this thread, there’s a workaround, though there haven’t been enough follow-ups for me to determine if that workaround is actually effective, though it does at least appear that the OP marked the workaround as a solution.

I saw that, but it doesn’t seem to be relevant to my situation.

  1. I haven’t seen the white/orange flashing he describes.
  2. His solution was to let the batter run down completely, and then plug it in and let it charge. My battery is already completely depleted and plugging it has not charged it at all.
  3. The battery stats his system reports look different form mine. Note the values of POWER_SUPPLY_CHARGE_FULL given in that thread.

If I’m understanding this correctly, my system seems to think that 0 is “full” so it’s not attempting to charge.

Hmm, yes, I agree with you. Seems like POWER_SUPPLY_CHARGE_FULL should not equal 0. I’m not enough of a Linux expert to know if that is something that can be manually edited, or if that’s something inherent to the battery. If you just have a bad battery, it would seem that the universe just doesn’t want you to have a laptop.

@Sitwon, you might wanna contact us via email to get a replacement battery.

I contacted support via email at about the same time I posted to the forums. They quickly shipped out a replacement battery and it just arrived yesterday. The new battery seems to have solved the problem. I would guess, from the lack of similar accounts on the forum, that this was an isolated incidence of battery failure.

I appreciate the responsiveness of the Purism support team in helping me solve this issue.

For the future, I would suggest considering other shipping methods, or giving the option to upgrade the shipping method. FedEx Ground is extremely slow when the destination is on the opposite coast. It took a little over a week from when I reported the problem to when the replacement arrived.


I’ve had the same problem with my Librem 13 battery recharging only sporadically after about 2 1/2 months

What I don’t know is whether the problem is with the battery or the charging mechanism.

Am I assuming correctly that it might be one or the other?

I’ve been reluctant to spend money replacing the battery when the problem might lie in the charging hardware…

I’m not sure if Purism Support would have any other diagnostic steps for you to try first, but in my case they determined I needed a replacement battery. After replacing it, it has been working fine ever since (about a year now.)

I would recommend contacting support directly.

Similar issue here.

First charge cycle reached 100% and I started using the laptop on battery power when it suddenly died an instant death, without warning, many minutes before the battery was ‘supposed’ to run out. Since then, I’ve not been able to charge it beyond 55%.

Grepping the boot log reveals the following load failure:

Failed to load DMC firmware i915/kbl_dmc_ver1_04.bin. Disabling runtime power management.

which sounds pretty relevant to me.

Did you find a solution to the problem you were facing?