Best way to do a full image backup of the entire eMMC?

Thank you guys.
I always thought that when a HKS is set to off, this means that the device was enabled (is working or switched on).
I was not shure if my reasening was correct.
Now I know :+1:

Now I have to wait for @Dos coming online…

For switching off the peripherals you need to place the switches into the “down” posttion while holding the phone in ‘portret’ mode.

1 Like

The intention is to keep the power consumption as low as possible in order to maximize chances of successful boot even with deeply depleted battery and under-powered USB source - so you’re supposed to put all hardware kill switches in off position (towards the bottom of the device) to disable the peripherals.

Of course it’s not strictly necessary. Usually everything will work just fine even if you don’t do that. I never do :stuck_out_tongue:


It sounds like the naming should be called toggled down against up, or bottom against top.

1 Like

Or, if the expression ‘kill switch’ had never been used, and it was just a ‘switch’, then readers would not be confused by being told to switch the peripherals ‘off’ before booting.

I’ll see about getting the description of that step clarified.


That’s what got me confused.
Just writing “switch off” the periherals would (for me) suffice.

1 Like

Hi @dos
Thanks for explaining.
I guess you missed my other question:

Can you help me with this?


Since @dos is not responding for whatever reasons, I ask my question to the community.

There is an updated/patched version of JumpDrive (created by @dos) and can be found here.

I do not know what to do when following that link.
Where is the modified JumpDrive?
I only see a download for “artifacts”, but that is not JumpDrive.
Any help is appreciated.

1 Like

Extract the downloaded file (, then extract the resulting purism-librem5.tar.xz, then follow these instructions:


Thank You, got it.
It never crossed my mind to check inside that zip file.
:+1: :+1: :+1:


Hi all.

Back again and I need a bit more help with Jumdrive.
I’m confused where to install the Jumdrive software.
Should it be installed on the L5 or on the laptop?

So far I’ve tried these steps.
I have installed (unzipped) the jumpdrive software in a folder on my L5.
Tried to run the script but it complained that it needed uuu (wich was not installed).
So I installed uuu on my L5 and started the script ( again.
All is done in Terminal.
Now it runs.

A text line appears:
Success 0 Failure 0 Wait for...

At this stage I power down my L5,
Remove the battery,
Press volume up, insert the USB cable (blinking red led appears)
Insert the battery (red led constant on)
Release the volume up button.
My L5 remains dark, nothing to be seen on screen.
Checking my laptop (running Live USB with PureOS latest iso), but no new USB device(s) to be seen.
What am I doing wrong?

1 Like

Confirm you are in flashing mode by turning on the Librem 5 while holding the volume up button. You may need udev rules, permissions in the plugdev group, and a restart of your host computer to have uuu detect the Librem 5:

JumpDrive - postmarketOS

1 Like

OK, got Flashingmode and Jumpdrive running.
At the host Jumpdrive reports Success 1 Failure 0
At the L5 I have the screen as expected.
However, there is no luks pw prompt (where should it appear? Host or L5)
Also, the L5 is not visible at the host.
lsusb does not show the L5
disks does not show the L5 eMMC

I switched USB cables, despite they have been working fine.

I’m stuck.
Any ideas?

1 Like

Did you execute the script using the host computer?

1 Like

Yep and it reported back with success = 1

1 Like

What should happen after flashing Jumpdrive is that your Librem 5 is detected as a USB device on the host. I suggest retrying the flashing procedure and seeing if anything changes. You can also use this more thorough guide for further debugging/troubleshooting steps:

1 Like

OK, I’m going to follow the steps from Lliure.
I will report back and thanx.

1 Like

OK, did read bits and pieces, check some requirements and all seems to be available.

Booted again and entering succesfull into flasmode with Jumdrive.
But still no eMMC partition available.

dmesg -w shows

usb-storage 3-4:1.2: USB Mass Storage device detected
scsi hosts5: usb-storage 3-4:1.2
usb3-4: USB disconnect, device number xx
usb3-4: new SuperSpeed Gen 1 USB device yy using xhci_hcd
usb3-4: new USB device found, iVendor=1209, iProduct=4201, bcdDevice= 5.18
usb3-4: new USB device strings: Mfr=1, Product=2, Serialnumber=3
usb3-4: Product: Librem 5
usb3-4: Manufacturer: Purism
usb3-4: SerialNumber: Jumpdrive
usb3-4: Set SEL for device-initiated U2 failed.
usb3-4: Disable of device-initiated U1 failed.
usb3-4: Disable of device-initiated U2 failed.
rndis_host 3-4:1.0: RNDIS init failed, -19
usb3-4: Set SEL for device-initiated U1 failed.
usb3-4: Set SEL for device-initiated U2 failed.
rndis_wlan 3-4:1.0: RNDIS init failed, -19
usb3-4: Set SEL for device-initiated U1 failed.
usb3-4: Set SEL for device-initiated U2 failed.

These messages are looping all the time, where xx is an incrementing number and yy is xx+1.

1 Like

That is unusual, and there are no similar issues. Are you using sudo dmesg -w for your command?

1 Like

Indeed I do. Typo corrected in my message.

I am using jumpdrive on my brand new L5.

1 Like

Okay, disconnect and reconnect the cable to the same USB port on the host, then if it does not work, try the other ones.

1 Like