I really don' t want to have to reflash my Librem 5 yet again

I have had to reflash my Librem 5 multiple times, like when the root filesystem ran out of space etc. I was running out of space again, but I was able to work around it by deleting all other kernels etc. Then I applied updates from the command line and that worked OK. Things were working fine until I made the mistake of applying the System Updates that the phone notified me of. After doing that, upon restarting and applying the updates, phosh (I assume is not working right). I can select an application and it starts, but pushing the up arrow at the bottom does nothing. Also touching the top line does nothing either. In fact, I can only end apps by using the kill command from the command line and can only turn off the phone either from the command line or the power button. Not really very useful in this manner.

I tried to install an earlier version of phosh from the command line by specifying the version on the command line. And of course there is no downgrade option with apt. I don’t know for sure that the problem is phosh, but that is the first thing I thought to try.

Any suggestions of how I might resolve this problem without reflashing yet again?


Hello, since the last update of phosh it’s not a tap anymore, you have to swip down the top arrow or swip up the bottom arrow

go to 1 min in this video:


Thanks very much. I never thought to try that even though that is what you do on all/most other phones because that wasn’t the way this one worked. I like the change though.

Thanks again.

1 Like