Black screen when sharing screen?

Hi there, to verify my crypto account on my exchange, I have to share my screen, to verify my hardware crypto wallet (trezor model t) that shows the address of my wallet. When I click on share, I only get a blacks screen as a result. I tried it with Chromium and with Firefox. I switched the switch of my camera/audio to on. Do I need to change a setting?


I have been searching a lot and found this. It has something to do with wayland, but do not know how to switch to Xorg, what could solve the problem? By adding this file, should this solve my problem? I found this in post Screen tearing in xorg


Jul '20

I fixed this issue by adding a file to location /usr/share/X11/xorg.conf.d/20-intel.conf with the following code:

Section "Device"
	Identifier "Intel Graphics"
	Driver "intel"

	Option "TearFree" "true"

This is another solution that I found elsewhere. But I am not sure wether this is a save solution. Unfortunatly I am not experienced in editing files and do not want to mess up my Librem 15. I also do not find a gear icon on the login page on my laptop.

This is a known screensharing bug with Wayland:

Unfortunately the easiest fix is to not use Wayland. You can use Gnome with Xorg at the login screen by selecting the gear icon before logging in, and you can use Xorg by default by modifying your /etc/gdm/custom.conf file and un-commenting WaylandEnable=false .

1 Like

I have solved it by verifying the wallet with my old Windows laptop.

PureOS uses Wayland by default. Switching to X11 should help.