Blank screen after failed, then "successful" login


#1

Please bear with me. This appears to be a different problem than other login blank screen/loop issues in this forum and the PureOS Tracker.

I am using PureOS on a Librem 13v3 with updates through 7/2. I use long passwords, so sometimes I mistype and have to go through the login again. Here is new behavior that I noticed recently:

  1. System boots normally to login screen after decryption.
  2. I enter the wrong password for my user ID.
  3. Re-prompted for password.
  4. I enter the correct password.
  5. Screen goes blank appearing to try to display the Gnome desktop.

I write appearing because what I end with is a mouse cursor and a blank screen. If I hit the Menu button (stacked icon) on the keyboard, I get a balloon with Copy, Paste, Show text. That leads me to think the system is still expecting a password.

Ctrl+Alt+F2 also yields a blank screen.

I have done “dpkg --configure -a”. The tracker item Gnome login screen does not start does not seem applicable; I do not think I am really logged in.

I have to power off to recover, though there may be some key sequence that could restore the screen of which I am unaware. (Interestingly, though my power switch is configured to power off, it actually suspends unless I hold it down for a long time.)

This is reproducible. I do not have problems when I type the correct password the first time, so this is a minor issue.

Before I run off to open a new tracking item, has anyone else seen this behavior? Thanks.


#2

Yes, have been experiencing this too; admittedly did not dig any deeper. Occasionally Crtl+Alt+Fx actually helps, but in other cases a reboot was needed.

Best,
Stefan


#3

Related to Login loop login fail


#4

It would be very helpful if you could report this to our bug tracker: https://tracker.pureos.net/

You can get logs (from another virtual terminal) using:

sudo journalctl -b > journal.log

And then upload the journal.log file to the issue report.


#5

Thanks to you both for responding. @mladen, this seemed different enough to me from the previous issues, because I did not seem to be actually authenticating. This line in the log, however, looks interesting:

  saba gnome-shell[988]: g_dbus_connection_call_sync_internal: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

I do not know enough to know if this message is ‘normal.’

I opened a new task for this issue, and I attached the requested log.


#6

I also suffer from the same issue as reported by @Wayne.