Blank screens after resume with multiple reboots

I have a Librem 15 v4. I cannot figure out where the problem here is. I am using Manjaro Linux (i3wm) but this problem happens even before the OS boots. I think it has something to do with resolution switching.

Here is the pattern. I suspend my laptop by closing the lid. Sometimes opening resumes the laptop just fine, especially if it is only closed for a short time. The display comes up black, I hit a key, and then the display comes on.

But if I leave the laptop closed for a long time (> 1 hour), when I open it I just get black screen. There is some backlight but it doesn’t seem like the full backlight. The system is actually running and resumed. It responds to poweroff by shuttung down. A few times doing ctrl-alt-f2 to get to console and then back fixes it, but this is rare.

The even weirder part is that I then poweroff completely. I turn it back on but there is no Purism logo at boot. I can see the SeaBIOS text show up quickly, then the resolution changing for grub and console, but the screen stays completely blank after this. Again, the system boots and is running, and hitting the power kicks off an OS shutdown.

I have to repeatedly poweroff and back on 6 or so times before I start seeing the grub and linux console messages again. It seems resuming from suspend gets the display in some strange state that is only fixed with multiple poweroffs.

As an experiment, instead of powering off, I tried closing and re-opening the lid 4-5 times. This indeed made the display come back. So there is at least some workaround instead of powering off multiple times.

I am using xfce4-power-manager. I’ve tried multiple kernels: 4.19 and 5.2. I’ve tried switching from intel to modesetting driver in X. The grub resolution is 1024x768x32 (though I’ve tried with it auto as well). I have i915 loaded on early KMS.

Any ideas what is wrong here? Thanks for any help.

1 Like

So any ideas on this?

I’m sorry to say this laptop is really not worth the price. The i915 driver suffers from problems just like described here:

Along with that, the trackpad is quite clunky. While copying text, it will sometimes just lock up and I have to take all fingers off the pad and start over.