Blockstream Satellite on Purism

Has anyone installed the blockstream satellite software on a purism yet?

Looking at the github repository it says:
There are currently binary packages to facilitate the installation in the following distribution/releases:

Ubuntu bionic (18.04)
Fedora 27
Fedora 28
CentOS 7*

As I understand, PureOS is based on Debian, what issues (as a complete noob) can I expect to encounter trying to install this?
At the moment i’m syncing a full node using a guide for Kubuntu, which worked fine, so i’m hoping that if I follow the Ubuntu instructions it will work out.

Does anyone have any tips?

As Ubuntu is also based on Debian, it’s reasonable to assume that it will install. ( > 90%)
If it does, it is also reasonable to assume that it will not break the system. ( > 99.9% )
For example, installing a deb package will not overwrite files owned by other packages.

1 Like

Great, thanks. I’ll update this thread when I’ve gotten further with the process.

Unfortunatly it doesn’t seem to work. when i enter:
sudo add-apt-repository ppa:blockstream/satellite

I get an error:
could not find a distribution template for PureOS/green

the whole output is:
Traceback (most recent call last):
File “/usr/bin/add-apt-repository”, line 95, in
sp = SoftwareProperties(options=options)
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 109, in init
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 599, in reload_sourceslist
File “/usr/lib/python3/dist-packages/aptsources/”, line 93, in get_sources
(, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for PureOS/green

Unfortunately, it will not work as the packages seem to depend on very specific versions of other packages.
(It could possibly be much more compatible if they cared)
But if it would, here’s how you’d do it:

I never used ppa. You could either try to download the packages directly from here:
or manually install the repository via the information from the ppa:

Add the repository: (remove that file to get rid of it again)
echo 'deb bionic main' > /etc/apt/sources.list.d/satellite.list
Add the corresponding key (trust all packages signed with that):
gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --keyserver --recv 5E4CECA7FA5F4561D5BF0397BA071931E00891B5
This failed for me, as it could not create a temporary file. Fixed with:
mkdir /root/.gnupg
apt update
If everything went well, you can list what you got:
cat /var/lib/apt/lists/*blockstream*amd64_Packages | grep Package

You can of course try to fix/ignore the missing dependencies, but from now on, your on you’re own :slight_smile:
(Also, potentially something might break.)

Thanks, i’ll study that. I’ve started working on other parts of the project. I’ve installed GNUradio amd working on gr-osmosdr:

I managed to input:
git clone git://
cd gr-osmosdr/
mkdir build
cd build/
cmake …/

and get:
Could not find the database of available applications, run update-command-not-found as root to fix this
Sorry, command-not-found has crashed! Please file a bug report at:
Please include the following information with the report:

command-not-found version: 0.3
Python version: 3.7.3 candidate 1
Distributor ID: PureOS
Description: PureOS GNU/Linux 8
Release: 8
Codename: green
Exception information:

local variable ‘cnf’ referenced before assignment
Traceback (most recent call last):
File “/usr/share/command-not-found/CommandNotFound/”, line 23, in crash_guard
File “/usr/lib/command-not-found”, line 93, in main
if not cnf.advise(args[0], options.ignore_installed) and not options.no_failure_msg:
UnboundLocalError: local variable ‘cnf’ referenced before assignment

any ideas what i’m doing wrong?