Blue Yeti Microphone working with PureOS?


#1

I tried to search the internet for how to get the Blue Yeti USB Microphone to work with linux (Debian), but no luck; most of the articles I find are 2+ years out of date.

Has anyone been able to get a Blue Yeti microphone to work seemlessly with PureOS? I will not have the money to buy a new microphone and I intended to make high quality videos for youtube for marketing purposes.

My goal is to use the Purism 15" laptop for business content production purposes, and the closest thing I could find was covering Jack Audio and Pulse Audio.


Microphone plug
#2

To be clear … you already have a Blue Yeti USB microphone?

Plug it in and do lsusb and post the line of output that is applicable to the microphone.

If a USB device shows up, probably look in syslog to see what additional messages if any were produced.

Are you implying that the microphone is recognised but does not work seamlessly? i.e. partially works but exhibits some kind of problem?


#3
  1. Yes, I already have a Blue Yeti USB Microphone.
  2. I did do lsusb and the line of output does not show up for microphone.
  3. the USB microphone does not show up at all in the list.

@kieran


#4

Try doing sudo dmesg -t -w and then plug the microphone you will see what’s going on.


#5

What are you looking for exactly from me using that command?

I am seeing a lot of “profile=‘unconfined’” and also a couple of:
[drm:vmv_sou_crtc_page_flip [vmwgfx]] *ERROR* Page flip error -16.


#6

dmesg it’s a tool to print the buffer messages from the kernel, but that output don’t make any sense because it’s related with virtual machines graphics driver, are you sure that the microphone it’s receiving power and data trough the cable you are using?


#7

Yes I am able to get power through the cable, no data though; not even through the command line (data). If it helps, I am also running PureOS in a virtual machine on Mac OSX High Sierra host.

One of the other things I saw in the very long message was it mentioning “graphics tablet USB device” or something similar.

Not directly related, but I was able to get the printer function working correctly to the PureOS Virtual Machine. This is only additional information to show I am getting things working within the virtual machine; it is not directly relevant to the microphone issue.


#8

Have you seen this: 1 2?
One solution can be true for many Linux distributions.
If the solution is not new, it does not mean that it does not work.


#9

For fault isolation purposes it would make sense to boot PureOS on a real machine and just test the USB microphone that way.

It goes without saying that doing lsusb in the virtual machine may or may not show any response at all - because the new USB device may show up in the host machine only and not be made available to the virtual machine.

So when you said that lsusb shows nothing for the microphone … was that from PureOS booted on a real machine or on a virtual machine?


#10

The PureOS was booted from a virtual machine @kieran. I cannot afford a second real machine at this, and definitely not this year. So you do you recommend I shelve this problem for now?


#11

OK, in that case, step 1 would be to see whether the microphone shows up and works in the host machine. I’m assuming that the host machine is a Mac and so there is zero chance that I can help you with achieving step 1. :slight_smile: You may be implying that step 1 has already been achieved.

The next step would be to configure the VM so that the device is available to the VM. Someone may be able to help out with that, but not me.

The final step would be to try to use the device from within the VM.

As for the question of affording a second real machine … well, if you just want to get an idea of Linux support for particular hardware, buy a Raspberry Pi. Cost: bugger all.

That runs Raspbian (Debian-based) so is fairly indicative of likely success in the Debian family (including Ubuntu, Mint, and PureOS). That could get a bit tricky because if your current device is a laptop then you may need a spare monitor / keyboard / mouse just to set up the Pi initially unless you can borrow / use a friend’s.

Once the Pi is set up, you can ssh in and do stuff even when the Pi is headless, provided that a) a suitable command exists and b) you know how to use it. (Or if you have a spare monitor, keyboard and mouse then you are a-ok to try things out directly.)

On the Pi, you should be able to use arecord for basic sound recording from a microphone - and aplay to play it back assuming that you have speakers connected, otherwise sftp to move the file back to the computer that you are connecting from and play the file there (but on a Mac you are on your own for how to do that).

To be honest, I haven’t had a lot of difficulty with audio sources and sinks in Linux generally, particularly USB. Unless the vendor goes out of its way to be difficult, it is plug and play.

I don’t think that’s a judgement that I can make for you - not knowing your level of expertise, special areas of expertise, level of perseverance, how much help you can get from any former (or current) Mac users in this forum, …


#12

In that case, I can tell you that when I first got that USB Yeti Microphone in hand, I immediately tested it with the Mac OSX host, and it was literally plug-and-play, everything worked fine. Even with the video creation software Screenflow for macs. It worked well during the audio test for OSX audio software that comes pre-installed.

So, next I would have to figure out how to get this working through the VM (Virtual Box). I am not trying another operating system nor am I getting a separate machine (at this time).

The Purism Mini-PC is looking like a good option, after it comes out and I can afford it. I already got a separate monitor with an HDMI connection. Finding a separate keyboard and mouse won’t be a problem.


#13

It’s a VMWare VM? Follow the 5th answer in here https://communities.vmware.com/thread/573617 I think MacOS is blocking the USB trough the VM


#14

The VM I am using is Virtual Box from Oracle. @uzanto


#15

You need to pass USB device to the guest in VBox using USB filter. Here’s how I’'ve passed my osciloscope to Windows guest (control software was only for windows):

[ruff@dei ~]$ VBoxManage showvminfo W7 | grep -A11 'USB Device Filters:'
USB Device Filters:

Index:                       0
Active:                      yes
Name:                        Unbekanntes Gerät 5345:1234 [1001]
VendorId:                    5345
ProductId:                   1234
Revision:                    1001
Manufacturer:                
Product:                     
Remote:                      0
Serial Number:      

So basically you need to identify your VendorId and ProductId using lsusb and then add a filter with it. You’ll need extension pack installed. And of course USB controller emulation (USB2 OHCI/EHCI). Here’s some more info.