Bluetooth connectivity still flakey

With the latest updates loaded, while HSP now seems to work with my bluetooth earbuds, now frustratingly for no apparent reason for streamed audio it insists on playing through the speaker and not the earbuds even though they are connected. Actually HSP stopped working as well so I’m thinking there is just something not right with the audio path. I have had this behaviour before and sometimes various combinations of shutting things off and on and rebooting works, but now it seems permanent with my earbuds…the crazy thing is that they were working first thing this morning and now I cannot for the life of me get it working again. Also why is it that the bluetooth earbuds or any bluetooth audio device I try not show up in sounds within settings?

Maybe this is a totaly different thing, but as I just want to help I tell you this:

I’ve got a laptop running with a debian derivate and Xfce. When I connect my earbuds I have to manually switch to them as output device via the sound widget in the tray.

Maybe you have to switch the output device, too, via pavucontrol or something.

Understood but the earbuds do not show up in the sound settings and there is no widget as there is no tray for me to select them. They are working again now, it seems I had to shut down the phone, shut off the earbuds, restart the phone, do not open the settings app, turn on the buds and let them connect, then loaded Kasts and it seemed to be back. Seems like something not consistently setting up the sound path correctly even though the bluetooth is working.

I was just about to post and ask if anyone else was having connectivity issues besides the audio stuttering. I had first assumed it was a weird issue with the OS when I flashed the firmware.

I reflashed the OS and connecting to devices, paired or otherwise, is unreliable. Sometimes it connects no problem. Other times the connection fails both from the phone to the device and from the device to the phone.

I’ve stopped using the Bluetooth for now :confused:

1 Like

I tried runing this command I came across with a search and it’s interesting that it returns this error:

purism@pureos:~$ sudo -H pactl load-module module-bluetooth-discover
[sudo] password for purism:
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

I’ve tried using bluetoothtcl to connect to devices when it does not connect automatically and it tells me the connection fails too.