Bluetooth stuttering

I’ve had that happen to me too. It works well enough until suddenly it is constant stutter or no output at all; no matter if re-pair the devices or reboot.

At first I would just wait a week or two and then it would suddenly start working again. Last time I tried fully shutting off the phone, including taking the battery out for about 30 seconds, and it seemed to help. But with how random this issue is, who knows if it actually helped or not.

Wait! It gets weirder. It’s only Spot(ify) that doesn’t stream over BT.
Music from Amberol and Radio (the app) stream properly over BT. Music from Spot does not; it comes from the L5 speakers.

Could this be a bug in the Spot app? If so, how is that possible?

I am also experiencing the problems you describe with my bluetooth headset.
When this happens, and to avoid a reboot, I turn off the Bluetooth, open the terminal and enter the commands:

purism@pureos:~$ sudo systemctl restart bluetooth
purism@pureos:~$ pulseaudio -k

Then I turn on the Bluetooth, I launch the settings application and on the Bluetooth page I reconnect my headphones.

It also happened to me that my Bluetooth speaker was detected as a mono speaker. But my solution was not effective for this problem.

I found another solution. Hopefully.

Recently, when I tried to connect to any output device, the L5 told me it was connected (lights and all), but the sound would still come from the phone.
Reconnecting or removing the device and reconnecting, did not make a difference.

Now, after I have started the music and connected the device (manualy in the bt settings), I swipe down from the top, select the sound settings and switch the output to something else than the headset and back again. Then the sound switches from the L5 to the external device.

Simple :rofl:!


Once I get my phone working on the cell network again I’ll have to try this out. Right now it’s sidelined while support figures out what’s wrong with it.