Boot fails because of system time reset

The System battery of my Librem 13 laptop was empty and so the system time is reset to 1.1.1970. and as a consequence all key check are failing. The simple solution would be to go to the BIOS / UEFI and set the current time and reboot. But … how to set the system with PureOS / PureBoot?

I tried to set the time at the command line. Setting the time with date -s succeeds … but, of course, after rebooting this time is no longer valid :frowning:

My system details:

  • Librem 13 v4
  • PureBoot-Release-15
  • Linux 5.4.69-PureBoot
  1. Boot into a PureOS live USB.
  2. Connect to the Internet, enable location services, then toggle Automatic Time Zone in the Date and Time tab to automatically synchronize the date and time.
  3. Open the Terminal and type sudo hwclock -w
  4. Reboot.

(I will organize / buy an empty USB stick and will tell about my success)

1 Like

If you want to use the exact same USB drive I frequently use for these sorts of low-level tasks, you can get it from Purism in their web shop.

I solved it, by the way You described: Creating a bootable USB with the latest PureOS (with Linux command dd), booted, turned on the time sync and booted from disk :slight_smile:

1 Like