Bootable Windows USB

I am getting frustrated, nothing seems to work on PureOS.

I tried to download Etcher, then I tried to run it and I keep getting this error:
root@md:/home/md/Downloads# ./balenaEtcher-1.5.122-x64.AppImage
No protocol specified
The futex facility returned an unexpected error code.
/tmp/.mount_balenasEXrms/balena-etcher-electron: line 10: 39683 Aborted “${script_dir}”/balena-etcher-electron.bin “$@” --no-sandbox

I tried to download Unetbootin, then I tried to run it and I keep getting this error:
root@md:/home/md/Downloads# ./unetbootin-linux64-702.bin
No protocol specified
qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland, xcb.


Does it really have to be this difficult PureOS / nothing works to create a simply bootable windows usb!

I tried through DD command too:
root@md:/home/md# dd if=/home/md/Downloads/Win10_21H1_English_x64.iso of=/dev/sdb1

But it looks like it never start/run/finish, neither i can call any progress.

I wasn’t aware that Etcher was able to make Windows Bootable USBs??

It can make bootable usb, and you just choose what .ISO you want to mount to it.

No it can make bootable Linux images, but has always said that for Windows you’ll need to use a different piece of software as it cannot do it. I might be referring to an older version, but this is how it was from before.

For graphical programs, don’t run them as root. Root didn’t start the GUI server and doesn’t have the permissions. For dd, try man dd.

1 Like

i tried dd and it finished, but when boot from usb seabios says: booting from harddisk, nothing happens???

If you’re going to use Linux to write a windows USB, you have to use unetbootin. As I understand it, Pureos uses Wayland, so you need to install the Wayland plugin for unetbootin.

FYI, the “proper” way to write a windows USB is using rufus on windows.

no, no, no. unetbootin rarely produces properly booting USB media IME.

To create Windows install media from Linux, the only reliable method is using Woe2usb.

From Windows, use Microsoft’s tool or Rufus, but Rufus has a lot of options which can be easily misconfigured

Oops, got some wires crossed, you’re right.

well i installed woeusb, but when i click start ask for authenticate password admin and after that nothing happens?

How do you install woe2usb?
a deb file does not work.
its gives a error:

Unable to install woeusb-build-deps:
The following packages have unmet dependencies

I’ve heard Ventoy works also, maybe try that? I don’t have any experience with this first hand, I always create Windows install media from another Windows device