Bootloop trying to install Mobian on Librem 5

I’m having trouble flashing Mobian on my Librem 5 Evergreen (r4).
For some reason, after I flash it, the phone goes into some kind of bootloop (green light flashing if unplugged, otherwise green, yellow, red).

If I flash byzantium, though, everything works fine and the phone boots without issue.

I’m flashing using the librem5-flash-image scripts that I modified a bit to work with downloaded images.
I’m using the same u-boot-librem5.imx in both cases and the librem5r4.img file contains either Mobian or Byzantium.

Any idea of what I could be missing? (note that I also tried the exact instructions from the mobian wiki using the devkit scripts without success)

Is it a known issue with the latest mobian images? (I was using mobian-librem5-phosh-20220717.img)

1 Like

OK, just tried with the latest pmOS install, which boots fine, so that indeed seems to be a Mobian image issue… will try to test with another one

1 Like

It’s great to hear that other L5 owners are trying out other options on the L5. I attempted both pmOS and Mobian about two weeks ago. pmOS worked great and ran smoothly. It doesn’t have some of the niceties of PureoS but works as expected.

As for Mobian, looking back at my notes, I also tried to flash “mobian-librem5-phosh-20220717.img”. The image flashed correctly but I got the light changing colour/boot loop. It sounds like we encountered the same issue. You could open a ticket with Mobian or maybe try an older build. Thanks for your input. I really like Mobian on my Surface Go tablet, so I’m going to try again with an older build. If it works, I’ll post back. Cheers!

2 Likes

Apparently the issue has been fixed, so we just need to wait for the next weekly image

3 Likes