Both INT 1 and INT 2 keys on Librem13v2 UK keyboard dead

xev and showkeys don’t notice that anything was pressed at all.

I saw Keyboard layout unable to recognize pipe, but the proposed solutions (hwdb file and/or setkeycodes) didn’t affect anything.

coreinfo shows firmware 4.6.500-gdd47634539-4.6-a86d1b-Purism-5

What I’ve tested:

  • Pressing the keys: Nothing happens
  • shift-pressing: Nothing happens
  • Run “xev” to see if X sees anything at all: Gives output for other keys, but not these two.
  • “showkeys” on the console: Same thing
  • “showkeys -s” on the console: Same thing
  • Run “xxd /dev/input/event0”: Gives output for other keys, but not these two.
  • After rebooting trying the keys in GRUB’s command line editor: Nothing happens.
  • Plugging in an external USB keyboard: That keyboard works fine.

Curiously with showkeys:

  • holding down right shift says “keycode 54 press” once, then about a second later repeats that a whole bunch of times
  • However pressing right shift and then holding down INT 2 (well, the “~#” key in UK layout) right after makes the “keycode 54 press” repeating not happen.

Similarly with “xxd /dev/input/event0” pressing INT 1 or INT 2 while holding shift stops the otherwise flow of data scrolling by…

What I take from this is that the hardware is noticing the key press, but is not generating scan codes (or whatever it’s called) to the OS. But I could be wrong.

I really hope this is a firmware problem that can be fixed. Is it maybe running a US keyboard firmware on a UK keyboard?

I tried following these instructions to upgrade coreboot, but seem to have gotten the same version string, and it didn’t fix the problem.

While waiting for an answer from Purism I remapped the menu key to \|:
sudo setkeycodes e05d 43

But that’s obviously not a solution.


Received my Librem 13 v2 with UK keyboard today and has the same issue. Enjoying everything else about this machine, but this issue is a bit of a blocker for me - pipe and tilde are kind of essential.

1 Like

Could you confirm how much of what I tried (e.g. showkeys, shift-the keys, etc…) you tried and saw the same effect?

I also got the tip to try unplugging the battery for a minute, in case there’s some chip that needed a reset. I unplugged the wide connector in the middle of the battery for 2min and plugged it back in. No change, unfortunately.

Any update on this? I was told on IRC that support is aware of the issue. But how’s it going?

Hi @Thomas_Habets,

I think if you do not have heard from support yet, it might be a good idea to send them an e-mail.
I could not find anything in PureOS issue tracker after a very quick search and the wiki does not seem to answer your problem either.

See the section Technical Support from the link below

Keep us posted :slight_smile:

I should add that I tested this with Debian, but have also booted a live Ubuntu USB stick. Same effect on both.

I got librem 13 v2 with uk keyboard.
Same issue.
I did more or less same as you, same results - no scancodes/events.

I then compiled a fresh kernel (linus vanilla 4.15) with CONFIG_INPUT_EVBUG so all input events get logged to system log directly from the kernel (without even going through the AT keyboard driver).
Again - no events for those two keys. (and possibly missing a couple of others weird keypresses such as fn+f1 - which i really don’t care about)

I think this is nothing to do with linux distro or software configuration. I think your assumption about firmware is most likely.

I’m waiting for support to get back to me, but in one email they asked me to try this:

  1. is this reproducible with Xorg (
  2. does keyboard layout ( has any effect on this problem
  3. is this reproducible on other operating systems (Mint, Ubuntu, Arch, Fedora, etc)

tl;dr for me: Yes, same brokenness. You might want to try too.

Yes, same brokenness. You might want to try too.

Thanks - but No point really. From the kernel input event logging I can see kernel isn’t seeing the events from hardware, therefore Xorg and anything else in userspace isn’t going to see the key press nomatter what distro, or keymapping you use.

I am currently resisting the urge to take my laptop apart and start probing the hardware. I guess i should leave it to the experts for now.


If you haven’t received email from me titled “[your order number] Librem 13v2 UK keyboard problem”, please contact support.

Same for me. I could not find a way to get anything from Linux seeing any event for these two keys.

@amaury You (and anyone else experiencing this) should probably contact support directly. The email mladen refers to gave me (and presumably others?) return-for-repair instructions.

I’ve got the same problem. :worried:

Dear customers,

if anyone else is having problems with UK keyboard models, please contact support.

To follow up for others:

After being sent back for repair these keys now work perfectly for me.


1 Like