Brand new Librem 14 - 1st boot. How hard can it be?

So I’ve got a brand new Librem 14. The whole works with pureboot bundle, anti interdiction bundle etc, with qubes.
So the instructions seem simple. I was given a link to the pureboot start up which has nothing about a qubes 1st boot, but whatever. I was told to start it with the Librem key inserted and then it will boot into qubes where I will be able to set my LUKS password. Sounds ok?
So, the laptop starts, the key does its thing, all good. Then it boots directly into the qubes LUKS password prompt page. This is not page I’m familiar with when setting the disk encryption pw. So, I think this strange. But, following the instructions I put in a new LUKS password which is rejected. But it does accept the default 12345678.

At this stage I’m already thinking things aren’t right. The login box appears slowly sort of like a television with lines that eventually clear. Inputting the pw has the dots appearing slooowly so it takes about 2 secs between each input. So when it begins to boot into qubes it takes forever and then I reach an error page telling me;

Warning: /dev/mapper/qubes_dom0- root does not exist
Warning: /dev/mapper/qubes/swap does not exist

Entering emergency mode

Press enter for maintenance
(or press Contol -D to continue)

Pushing ctrl-d gives me

[334. 1808461 ] dracut-initqueue[397]: Warning: Not all disks have been found
[334. 1809451 ] dracut-initqueue[397]: Warning: You might want to regenerate your initramfs.

I can’t get past here except by pushing enter to get out of a sea of ******************************
I get to a prompt
I’m not familiar with this so I can only reboot from here.

So if I restart for some reason it doesn’t accept “12345678” as a pw now. I have to fuck around maybe 4 or 5 times to get it to accept, and then its the same cycle. Why does it accept it sometimes but not others??

I’ve had qubes fuck up on me before with this slow pw thing that was only resolved with a reinstall, but this time I not even getting into qubes. After putting in the pw the progress bar that goes across as you boot into qubes is painfully slow. As I said, I’ve seen this before and it didn’t end well.

I suppose I could install qubes again but i lose the advantage of the key and vault i bought.

I am hoping that qubes has not been installed and I was told that this is an “OEM” install and that I could set up my preferences at the first boot, but this looks like its already been installed which will displease me immensely, but maybe I’m wrong having never seen an OEM install.

I’ve tried rebooting without the key which gets me to a myriad of options that I’m not game to access, but I can get to a “default boot” or something like this, same result.

Any ideas wise ones?

This laptop cost me just under $4000 aud to land this thing here, so the word disappointing goes nowhere to describe this.

How hard can it be? I followed every instruction which was minimal to no avail.

And yes, this is a job for Purism support but being Sunday afternoon and back to work tomorrow I’m hoping there is something that can me going here. What was meant be an enjoyable afternoon now has me totally pissed off. Sorry for the rant. My wife’s had enough of it so I thought I’d let a bit out here!

The online support for Qubes on the purism site is nonexistent. I did notice on one video, they said that qubes ships on a separate USB? did you get a separate USB drive. I use Qubes on my desktop so I"m really comfortable with it. The install process can be a bit involved.

My guess is Qubes is not actually installed on your laptop. You will need to use that other USB drive, maybe boot from it, to physically install qubes on the laptop. Then the boot process should work? Just guessing.

I love Qubes, it is really great. Sorry you are having a poor start to your Purism and Qubes experience. I have a Librem 15 that I just run PureOS on. I’ve enjoyed both though.

Thanks for the reply. I have been using qubes for years so am very well versed in its use and installation.
I received three usb sticks. One is the Librem key to check integrity (all ok), one is a stick with live Pure OS on it (of no consequence here), the other is the Librem Vault which I haven’t had a need to use at this point. There are no other usb sticks.
If qubes needed to be installed why would it boot into the disk encryption pw page of qubes? Doesn’t make sense.
I have emailed support but I may end up just installing qubes which makes a joke of $299 for anti interdiction.
I’ll see if I get a timely response.

An update here.

The instructions are that I would be asked for a disk unlock phrase and then press enter which would take me to the qubes configuration process. Yesterday this just kept returning me to the same window which then had me muck around with default passwords. So today, I did the same. Press enter, same thing. Reboot 3 times and then on 3rd reboot pressing enter I get to the qubes configuration process.

Why the inconsistency?? As I type its doing its thing but this is no way to fill me with confidence.

Frustrating, but hopefully on the road to success.

1 Like