Brave installation- someone hold my hand?!


#1

I bought a Librem13… I thought these were going to be user-friendly, and I wouldn’t have to know how to program to use the damn thing… as advertised by Purism. My fault I guess, as I thought I could just point and click my way through life like a Mac or PC. Turns out I can’t even install the Brave browser (I need Brave to use my Trezor wallet).

I know nothing about working in the terminal, so the existing article about installing Brave means nothing to me. Can I just copy and paste the text into the terminal? I literally have no idea what I am doing and currently really regret this purchase.

And the space bar is terrible on the keyboard- it only registers a tap in the middle third of the key, as though it rocks on a central switch. Will wear out my backspace key pretty soon I think with a ll the corrections.

Any help would be appreciated!


#2

No worries. There is a bit of a learning curve if you don’t want to use the things that come on your Librem but this is the case for any and all operating systems you will come across.

Regarding installing Brave (which I also use), members of this forum have made a guide of sorts for it:

You would copy and paste the text into your terminal, yes.


#3

Also each line is its own command, so press enter after pasting it. The gaps between lines are just formatting.


#4

Follow the instructions for Debian on Brave Browser’s website:

https://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux

Brave has not yet been packaged for ANY linux distribution in the regular software repositories so you must use the terminal to get it, no matter what linux distribution you are on. It could not be simpler to do. Open the terminal and then do as they say on their website, i.e. copy and paste the following five lines in order and press enter after each one.

sudo apt install apt-transport-https curl

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

echo “deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main” | sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update

sudo apt install brave-browser


#5

The beauty of this, is that while initially daunting for you, this will become an excellent primer for the future. There might be a GUI for the things you want to do on Linux, but regardless, you can do everything via the terminal.


#6

I did do a bit of due diligence and found this post before posting my question, but not all that much happened when I tried to butcher my way along.


#7

This is what I needed! One command at a time worked a lot better than trying to jam it all down it’s throat at once.

Success on the Brave install, I appreciate the replies.

However, I need to install some udev rules. I have a feeling I am probably breaking some security/privacy basics by adding this, but meh, I am free to mess up my stuff as I wish, right?

This is what I have, but I don’t know what to do with the downloaded files. I’m guessing one of them has the lines of code I need, but I can’t figure out what program to use to open up those kooky extensions. Any suggestions?


#8

As you say,

I am free to mess up my stuff as I wish

You should not open or extract a .deb file. The .deb file is the thing that you want to install.

Easiest method is just to double click the .deb file from within the file explorer. If for some reason that doesn’t have the correct association then you can alternatively do it from the command line.

sudo dpkg -i path-of-dot-deb-file

e.g.

sudo dpkg -i ./trezor-udev_2_all.deb


#9

From the terminal/command line you can also run

sudo apt install /path/to/file.deb


#10

Just chiming in, stick with your Purism laptop. Making the change to Linux will be very rewarding. Learning curve for sure but lots of reward.

But to the topic. I also have a Trezor wallet which runs perfectly in Firefox. I’ve been and done Brave on linux systems and it runs ok. But, and my big but, is that my tablet returned messages to me that Brave was trying to access my camera and mic at various times. I communicated with Brave support who initially denied this, but after this kept happening they then put it down to a bug. Hmmm.
Brave is now gone and I use Firefox which I have hardened up, or Pale Moon for some sites. I would just relay my Brave experience. The Trezor works perfectly Firefox.


#11

Umm… I assume you didn’t mean any time where the website you are using would be attempting to use those things. As someone who uses Brave nearly exclusively, I’d be appreciative if you could quantify your claims a little more.


#12

I’ll quantify as much as I can. I’m not sure if its a third-party app or the native Samsung thing. The latter I think as I dont recall installing a third party one. It reports accurately from my experience. It returned, on multiple occasions when the tablet was just sitting there that it Brave was trying to access camera and mic. No browser open, hence no web page activity. On my tablet I had Brave, Firefox an Epic installed. Brave was the only one that was picked up. Further to this it did the same on my wife’s tablet.

When I couldn’t get a satisfactory response from Brave support I just uninstalled it from everything.


#13

Ahh you are speaking about android permissions then. If it was a Samsung device, it could be that Bixby had a hook in so that you could ask it via voice to perform certain functionality. However, since Android 7, I think, permissions have to be explicitly given.

As Android is a multitasking OS, the browser being active doesn’t mean that it can’t be active in the background. If you were, for example, using a webpage that was using those two pieces of hardware, and then pushed the home button, you will see that Brave is still trying to access those pieces of hardware. This is more a device lock, than active use.

What your describing, to me, sounds like something any app designed to use the webcam or microphone could exhibit if used in a manner that cause it here.

Now if you are on an older version of Android, permissions and settings were bundled into only a few things, and so while the system might be reporting web and microphone access, this could just be a hold over from how those permissions were bundled.

All of this said, I’m glad you have found a solution you are comfortable with, but I don’t think Brave is doing anything wrong on Android that Chromium wouldn’t also do.


#14

Firefox works for you? That’s odd as mine won’t recognize the wallet; it tells me to install the Trezor bridge. Since Brave and the Trezor wallet communicated fine on my Mac, I thought screw it, I’ll just use Brave instead of installing the bridge. However, as you can see above, Trezor now wants me to install those udev rules to work with Brave. I’ll try the rules first, and if I bugger that up, I’ll come beg for more help to install the bridge!

I have a Trezor Model T.


#15

Das ist gut! Wallet works with Brave, and the udev rules appear to have installed correctly. Or i just signed everything over to China, I can’t verify either way really.

If I get a bit more confident with this OS, I’ll consider putting in an order for the phone again. I cancelled it when the Covid attack began, as I was getting tired of so many delays. Once the phone is available in the fall (hopefully), it would be a fun project. Also, the phone is kinda big. I have giant hands, but I don’t like the “iPad mini in my pants” look.


#16

Yes, I had to install the Trezor bridge with Firefox but it works seamlessly. But, no matter, whatever works for you. Glad that you got it happening.

Stick with Linux!

With regard to Brave after I got these notifications I checked the Brave permissions just to be sure, and it didn’t have permissions for either camera or mic, as I already knew. I did provide all of the info to the Brave people but they had no explanation really after I told them the tablet make, model etc. As for Brave with the camera, I am sure that you are correct that its most likely benign. But I’m at the stage where I don’t trust anything really and I just try to mitigate what I can.