Broken Librem 14 boot process

After multiple months of wait I have finally received my Librem 14.

After upgrading the RAM and SSD, I proceeded to install Arch Linux from USB…

And it won’t boot! I’m stuck in the Heads GUI

No amount of trawling around ever gets me to an OS boot menu.
Heads apparently cannot find the boot options from my boot partition. It does find options form USB media though…
I have since tried Alpine Linux, with the exact same result: successful install, no luck actually booting from the SSD. and it’s not even giving me any useful logs as to why it’s no-oping…

I have also tried QubeOS but I couldn’t even get all the way to the end of the install because its GUI does something awful with the Librem trackpad input (some kind of weird absolute positioning that left me stuck incredibly frustrated at the timezone picking step).

When I tried to manually trigger a boot from the recovery shell (which definitely finds the correct /boot partition with the expected kernel/initrd from previous OS install) with kexec-boot it just hangs forever after saying it’s starting the new kernel.

At this point it looks like all I got is a really expensive brick…

Has anyone had success installing a different OS on the Librem 14? How did you do it? Am I missing some crucial step or is my unit just defective?

By the way, why on earth does it take some kind of bios flash to merely update the default boot device?

1 Like

Update: Pureboot is definitely to blame, although it’s not entirely clear what the failure mode is (cf, no useful logs on failure to show boot options)

I tried simpler installs without LUKS/LVM and pureboot/heads still wasn’t cooperating, so I went ahead and flashed coreboot/seabios over it and now I can boot out of the SSD.

It’s a damn shame that the advertised secure boot is so badly broken it won’t even tolerate another linux variant, but at least I can use my computer now.

Is this a know failure mode of pureboot? Was I doing something wrong and failing to read the docs? Are there any plans to have pureboot cooperate with distros other than PureOS, and give some more useful logs when failing to boot/show boot options?

Bummer you had problems, I wonder what broke.
I installed Fedora without too may problems with Heads. It’s been too long to remember my process but the only problem was resetting the Librem Key keys for the new OS.

Pureboot has specific requirements w/r/t partition layout etc. You need to have a dedicated, non-encrypted /boot partition. Plenty of other users running Fedora, Qubes, Arch, etc without issue.

Your best bet for real-time help with these issues is likely to be the Matrix community/heads channel

I had a dedicated non-encrypted boot partition, and a bios_grub partition on my GPT partition table. Pureboot was clearly able to detect the boot partition, read its contents (it complained about lack of signatures), write to it (it wrote signatures/checksums/otp/…) but somehow it couldn’t go as far as listing the boot menu.

Out of curiosity, do you or any of the other people that successfully installed a 3rd party OS w/ pureboot do it on a librem 14? The firmware image is different for each laptop so it’s technically possible the bug is specific to the librem 14, or even to the revision of the firmware that got flashed on my specific machine.

Either way, the lack of legibility is highly problematic: if pureboot cannot find any entries to list when trying to show the boot menu, surely it should display a message to that effect, ideally with relevant logs/diagnostic info, instead of silently jumping back to the previous menu.

I run Arch with an ext4 /boot partition and the rest being btrfs in a luks volume on a L14 without any issue. I’m not sure what is the problem you face, but it’s definitely possible to run almost anything on a Librem 14, provided you don’t have an alien grub conf (which is not the case on Arch, at least for me)

1 Like


do you or any of the other people that successfully installed a 3rd party OS w/ pureboot do it on a librem 14?

I installed Qubes 4.1 on my Librem 14 (that had PureOS on it when shipped) with no problems… and Qubes is known for being finicky with hardware. I had to tinker a bit to get my Librem Key configured for the new setup but beyond that it has been one of the smoothest Qube installs I have done. The Pureboot / Librem Key combination is my favorite boot platform to date.

Have you tried reinstalling Pure OS and getting it running once again? You know that works. Then maybe try again with Arch (instead of multiple reattempts after previous failed attempts.) There might be some detail your are missing in the Pureboot configuration that is causing the trouble. PureOS is a known variable which might help troubleshoot your Pureboot issue.