Bug: Code.puri.sm not reachable / down


#1

Hey forum, I hope the label “Infrastructure” is correct.

I can not reach code.puri.sm, which hosts the data necessary for build coreboot (Building coreboot from source (official script)).

user@localhost:~/purism_librem/building-coreboot$ ping 9.9.9.9
PING 9.9.9.9 (9.9.9.9) 56(84) bytes of data.
64 bytes from 9.9.9.9: icmp_seq=1 ttl=59 time=8.60 ms
64 bytes from 9.9.9.9: icmp_seq=2 ttl=59 time=26.3 ms
^C
— 9.9.9.9 ping statistics —
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 8.603/17.495/26.388/8.893 ms
user@localhost:~/purism_librem/building-coreboot$ ping puri.sm
PING puri.sm (138.201.183.172) 56(84) bytes of data.
64 bytes from web.puri.sm (138.201.183.172): icmp_seq=1 ttl=55 time=32.7 ms
64 bytes from web.puri.sm (138.201.183.172): icmp_seq=2 ttl=55 time=32.9 ms
64 bytes from web.puri.sm (138.201.183.172): icmp_seq=3 ttl=55 time=50.0 ms
^C
— puri.sm ping statistics —
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 32.778/38.585/50.045/8.103 ms
user@localhost:~/purism_librem/building-coreboot$ ping forums.puri.sm
PING forums.puri.sm (138.201.228.33) 56(84) bytes of data.
64 bytes from forums.puri.sm (138.201.228.33): icmp_seq=1 ttl=55 time=32.7 ms
64 bytes from forums.puri.sm (138.201.228.33): icmp_seq=2 ttl=55 time=32.5 ms
64 bytes from forums.puri.sm (138.201.228.33): icmp_seq=3 ttl=55 time=51.8 ms
64 bytes from forums.puri.sm (138.201.228.33): icmp_seq=4 ttl=55 time=95.2 ms
64 bytes from forums.puri.sm (138.201.228.33): icmp_seq=5 ttl=55 time=34.1 ms
^C
— forums.puri.sm ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 32.565/49.321/95.218/24.071 ms
user@localhost:~/purism_librem/building-coreboot$ ping code.puri.sm
PING code.puri.sm (138.201.183.166) 56(84) bytes of data.
From proxmox1.puri.sm (138.201.224.153) icmp_seq=1 Destination Host Unreachable
From proxmox1.puri.sm (138.201.224.153) icmp_seq=2 Destination Host Unreachable
From proxmox1.puri.sm (138.201.224.153) icmp_seq=3 Destination Host Unreachable
From proxmox1.puri.sm (138.201.224.153) icmp_seq=4 Destination Host Unreachable
^C
— code.puri.sm ping statistics —
6 packets transmitted, 0 received, +4 errors, 100% packet loss, time 5065ms
pipe 4

Any idea about this?


#2

The purism repositories are now on source.puri.sm instead of code.puri.sm (as we moved from gogs to gitlab).
The script from that build coreboot thread links to the new URL (though the changelog link needs to be updated)