Bugs in Byzantium (anyone else?)

I have two very annoying bugs on my Librem 5 running Byzantium.
While they are not dealbreakers, it would be nice to know where they are tracked (assuming that they are tracked) and if there is some new version or workaround to fix it today.

Problem 1: Firefox sometimes does not render the whole window
Gnome Web works fine, but it’s just so much slower compared to firefox that I avoid it even if I have this rendering glitch

Problem 2: Some applications (most notably Gnome Feeds)
The page jumps up most of the time when scrolling, even though I’m calmly and slowly scrolling down all the time. Scrolling in most applications is smooth, but for some reason Gnome Feeds jumps like this. I remember seeing this in another app a few weeks ago as well, but I don’t remember which one and I’ve tried to find it again, but either the other application has been fixed in an update or I’ve uninstalled it.

Another thing worth noting, the video is choppy because I’m recording the screen. When I’m not recording scrolling in most applications is very smooth (with the exception of Gnome Feeds of course!)

Problem 1 can be solved by updating Mesa, so look out for it being updated in the future.

Problem 2 - are you using Flatpak?


Awesome! :slight_smile:

Gnome Feeds I have installed as a flatpak yes. Could installing it from source solve the problem?

I just found that Gnome Feeds is also available as a PureOS package, works great now!

That issue with GTK3 apps inside Flatpak comes from lack of https://source.puri.sm/Librem5/debs/gtk/-/merge_requests/28 in flatpak runtime’s GTK3. This isn’t really fixable upstream; we carry these patches in PureOS, so at least non-flatpaked apps can use that workaround, but unfortunately that doesn’t help the flatpaked ones.